10:00:22 <Brooke> #startmeeting
10:00:22 <huginn> Meeting started Wed Oct  5 10:00:22 2011 UTC.  The chair is Brooke. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:00:22 <huginn> Useful Commands: #action #agreed #help #info #idea #link #topic.
10:00:32 <Brooke> #topic Introductions
10:00:33 <paul_p_> Brooke, ok
10:00:41 <ropuch> #help
10:00:41 <Brooke> Haere Mai!
10:01:00 <Brooke> introduce yourselves using #info if you want the minutes to show you were here
10:01:13 <kf> #info Katrin Fischer, BSZ
10:01:25 <slef> #info MJ Ray, http://www.software.coop
10:01:28 <chris_n2> #info Chris Nighswonger, FBC, 3.4.x Release Maintainer
10:01:29 <thd> #info Thomas Dukleth, Agogme, New York City
10:01:31 <jransom> #info Joann Ransom HLT, NZ
10:01:32 <sekjal> #info Ian Walls, ByWater Solutions, 3.6 QAM
10:01:36 <ColinC> #info Colin Campbell PTFS-Europe Ltd
10:01:36 <paul_p_> #info Paul Poulain, BibLibre
10:01:36 <ropuch> #info Piotr Wejman, CSNE Library, Poland
10:01:39 <magnuse> #info Magnus Enger, Libriotech, Norway
10:01:44 <rangi> #info Chris Cormack, Catalyst IT
10:03:24 <Brooke> apparently we have a placeholder on freenode
10:03:36 <Brooke> #topic Roadmap to 3.4
10:04:09 <Brooke> chris squared?
10:04:13 <chris_n2> everything is moving along well with 3.4 maintenance
10:04:26 <chris_n2> the 3.4.6 will move out on the 22nd of this month
10:04:46 <chris_n2> the plan is to keep releasing as long as we have a flow of patches for 3.4.x
10:05:01 <chris_n2> thanks to everyone for all of the good work!
10:05:05 <chris_n2> and that's it
10:05:07 <Brooke> everyone++
10:05:11 <Brooke> any questions?
10:05:46 <kf> chris_n++
10:05:51 <Brooke> #topic Roadmap to 3.6
10:06:17 <rangi> we are in feature freeze, string freeze starts very soon
10:06:41 <rangi> to be ready for the release on the 22nd
10:06:56 <rangi> if you want stuff in, get it signed off asap
10:06:57 <paul_p_> I've added a specific point yesterday, about BZ5877, let me know when I start speaking of it
10:06:57 <kf> soon was 8th?
10:07:01 <rangi> yup
10:07:16 <rangi> 2 weeks for translators
10:07:40 <rangi> bugs that dont introduce new strings will still be pushed, and any security ones
10:07:41 <paul_p_> #info String freeze for 3.6 in 3 days (oct, 8th)
10:07:42 <kf> fredericd: around?
10:08:06 <paul_p_> kf, fredericd works on french translation like a mad ;-)
10:08:13 <kf> was wondering if fredericd can update pootle
10:08:16 <kf> at this date
10:08:29 <Brooke> #help fredericd to update pootle
10:08:33 <kf> there are no 3.6 folders yet where you can upload your files
10:08:48 <rangi> yep, as soon as after the 8th would be great
10:08:48 <paul_p_> kf, right
10:09:07 * chris_n2 suggests delaying the 3.4.6 release a day or two in light of the 3.6.0 release on the 22nd
10:09:16 <kf> +1
10:09:20 <paul_p_> #info Jonathan Druart, BibLibre, France, applied as QA assistant for 3.8
10:09:27 <rangi> +1
10:09:43 * clrh #info Claire Hernandez, BibLibre
10:10:09 <Brooke> so let's see bug 5877
10:10:09 <huginn> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=5877 enhancement, PATCH-Sent, ---, paul.poulain, ASSIGNED , Offline circulation improvements : upload all files, apply at once
10:10:33 <oleonard> #info Owen Leonard, Athens Count Public Libraries
10:10:36 <rangi> Brooke: did we want to see if any more votes for delaying 3.4.6 ?
10:11:09 <paul_p_> owen has tested the bug, is probably about to signoff, and is suggesting to add KOCT firefox plugin to git. I agree it's a good idea, and was suggesting to have a dedicated git project for it
10:11:09 <Brooke> fine vote on then :)
10:11:10 <thd> +1
10:11:50 <Brooke> please use vote instead of suggest or message me or summat. I'll be barreling through this stuff. It's a long agenda.
10:11:58 <paul_p_> oups, sorry, I missed that chris_n2 called for a vote. +1 for me
10:12:00 <oleonard> My suggestion was that it be in git somewhere, and having its own dedicated project is one option
10:12:06 <kf> #agreed delaying the 3.4.6 release a day or two in light of the 3.6.0 release on the 22nd
10:12:14 <kf> no votes against ;)
10:12:24 <Brooke> ty
10:12:41 * chris_n2 gets to sleep in that saturday now ;-)
10:12:49 <kf> :)
10:13:09 <kf> I think the firefox plugin might change with new versions of firefox, different timeline than koha has
10:13:24 <kf> so having it on the public repo but as a separate project does make sense to me
10:13:35 <magnuse> +1
10:13:41 <chris_n2> +1
10:13:45 <paul_p_> kf, the plugin is very small, until now we had nothing to change, but it's the main reason = be able to release ne versions of the plugin when needed
10:14:02 <paul_p_> s/ne versions/new versions/
10:14:22 <paul_p_> +1 from me, of course ;-)
10:15:05 <christophe_c> #info Christophe Croullebois, BibLibre
10:15:10 <christophe_c> hi
10:15:26 <slef> +1 from me - any chance of bringing the extensions web page back in some form, for that sort of thing?
10:15:47 <kf> I think that page needs someone to host it probably
10:16:14 <christophe_c> +1
10:16:28 <Brooke> #idea bring back the extensions web page
10:17:05 <paul_p_> not sure we need to bring back the extensions page, it could just be a page on koha-community.org (or was it what you were thinking of ?)
10:17:14 <rangi> yup, we can point the dns anywhere just need someone to set up the site and maintain it
10:17:15 <chris_n2> are we talking about an entirely different project? ie different webpage, wiki, etc?
10:17:16 <slef> I wonder if the directory plugin used on the main site for support directory could do a directory of extensions. I'll go look
10:17:16 <paul_p_> (because iirc, we had an independant website)
10:17:26 <chris_n2> or just a different repo on git.kc.org?
10:17:41 <slef> yeah, we used to have an independant website, but we're already a bit stretched for admins IMO
10:17:42 <paul_p_> chris_n, I think we need a different repo and a specific webpage to speak of the module
10:17:52 <paul_p_> (explain how to install it...)
10:18:15 <kf> paul_p: different repo is agreed on I think - presentation to be decided
10:18:27 <kf> having it in the official firefox plugin directory woudl be good too
10:18:42 <Brooke> #idea listed on the firefox directory
10:19:05 <paul_p_> kf, it's already in the ff directory
10:19:09 <paul_p_> (or i missed something)
10:19:15 <oleonard> Yes it is
10:19:29 <hdl> it is not certified though
10:19:31 <Brooke> I smell a link.
10:19:36 <paul_p_> please welcome asaurat, which is Adrien, new BibLibreros, that started on monday.
10:19:37 <oleonard> KOCT?
10:19:37 <wahanui> KOCT is Koha Offline Circulation Tool or https://addons.mozilla.org/en-US/firefox/addon/koct/
10:19:47 <Brooke> ta
10:19:53 <paul_p_> wow ! wahanui is usesull ! great day !!!
10:19:55 <hdl> #info Henri-Damien LAURENT biblibre
10:20:08 <Brooke> we talked out on this bug?
10:20:24 <kf> welcome asaurat :)
10:20:42 <paul_p_> I think it's OK. The remaining question being = who create git.koha-community.org/koct.git ?
10:20:54 <paul_p_> rangi, can you ?
10:21:06 <rangi> gmcharlt can
10:21:29 <paul_p_> ok, i'll ask him if he don't read the logs of the meeting
10:21:40 <slef> paul_p_: http://wiki.koha-community.org/wiki/Website_Administration#Host_and_administrators_4 says hdl can?
10:21:49 <asaurat> thx kf :)
10:22:07 <asaurat> #info Adrien Saurat, BibLibre
10:22:18 <Brooke> #topic Voting on Roles for 3.8
10:22:29 <Brooke> moving on from the minutia of the agreed upon...
10:23:04 <kf> #agreed create a new project on git.koha-community.org for the KOCT firefox plugin
10:23:29 <Brooke> arright
10:23:35 <Brooke> let's go for low lying fruit
10:23:36 <slef> (bum! I don't have permissions on the directory plugin on the website at the mo, so I can't tell if we could use that for extensions - sorry)
10:23:47 <paul_p_> #agreed paul suggest git.koha-community.org/koct.git as name
10:24:32 <Brooke> okie dokie
10:24:57 <Brooke> doing this from the bottom to the top, cause I can.
10:25:11 <Brooke> votes for and again me for Bus Driver
10:25:14 <hdl> slef: it says also that chris can...
10:25:25 <magnuse> #link http://wiki.koha-community.org/wiki/Roles_for_3.8
10:25:42 <paul_p_> "bus driver" = is it just a joke, or there's some english subtilty i miss ?
10:25:45 <Brooke> nope
10:25:51 <jransom> person in charge
10:25:54 <Brooke> I'd like community assent for chairing
10:25:57 <jransom> gets us places
10:26:02 <thd> +1 Brooke driving on both sides of the road
10:26:05 <Brooke> I don't feel like I was ever given it and it freaks me out
10:26:13 <jransom> +1 for brooke being the shepherd
10:26:15 <magnuse> +1 then
10:26:17 <paul_p_> +1 too
10:26:22 <ColinC> +1
10:26:26 <rangi> +1
10:26:28 <ropuch> +1
10:26:30 <slef> +1
10:26:30 <chris_n2> +1
10:26:30 <kf> +1
10:26:38 <kf> now we need an agreed :)
10:26:46 <sekjal> +1
10:26:50 <Brooke> #agreed I'm stuck with this for now.
10:26:59 <chris_n2> lol
10:27:04 <Brooke> #info Packaging Manager
10:27:04 <fredericd> #info Frédéric Demians, Tamil
10:27:29 <paul_p_> Brooke, what about going back to 3.6 and ask the question to fredericd ?
10:27:30 <Brooke> did this need to be a single person or is it valid to have both Mason and Robin?
10:27:30 <kf> #agreed Brooke is elected to chair the meetings (Bus driver)
10:27:43 <Brooke> Paul I'd rather not.
10:27:46 <paul_p_> ok
10:27:56 <paul_p_> will ask him privately
10:28:45 <kf> I think both are not here right now :(
10:28:57 <magnuse> i think it makes sense to have 1 person in charge of creating the official packages?
10:29:17 <Brooke> yeah I'm skippin this for now until one or the other shows, hopefully both
10:29:24 <kf> not sure they will
10:29:26 <kf> only getting later for nz
10:29:33 <Brooke> indeed
10:29:34 <paul_p_> they're sleeping
10:30:07 <Brooke> #info need clarification on Packaging Manager; might have to wait for next meeting.
10:30:07 <paul_p_> I think magnuse is quite right = 1 person make sense for packaging
10:30:10 <rangi> i vote eythian in charge, mtj as sidekick
10:30:10 * thd sleeps at the keyboard regularly
10:30:22 <kf> rangi: agreed
10:30:23 <paul_p_> except if one packages for Debian, one for RedHat for example
10:30:34 <chris_n2> rangi: +1
10:30:38 <magnuse> rangi: +1
10:30:49 <Brooke> okie dokie rangi has moved for Robin with MTJ as a helper
10:30:57 <magnuse> +1
10:31:09 <paul_p_> +1
10:31:10 <jransom> +1
10:31:13 <christophe_c> +1
10:31:15 <sekjal> +1
10:31:23 <thd> +1
10:31:41 <ColinC> 1
10:31:49 <Brooke> #agreed Robin is Packaging Manager with MTJ assisting
10:31:59 <Brooke> (this is what you get when you're not present. XD)
10:32:20 <Brooke> do we have a proper candidate for Release Maintainer?
10:32:35 * Brooke was secretly hoping that Chris Squared would volunteer for life...
10:32:39 * chris_n2 runs and hides :-)
10:32:54 <kf> I was secretly hoping he would do it for 3.6 - because he is good at it :)
10:33:09 <kf> for life is a bit too scary, you have to make him do it one release after the other ;)
10:33:28 <chris_n2> if no one volunteers by release time, ask me again :)
10:33:43 <paul_p_> chris_n2, you've 2 options : either you accept to continue or we ask publicly for someone else.
10:34:07 <kf> we can ask and wait if someone volunteers
10:34:09 <paul_p_> chris_n2, I personnaly don't want to force anyone. But you're doing a good job so if you want to continue, i'll vote.
10:34:13 <Brooke> oh he's more than two options. He could move to the south of France. XD
10:34:14 <kf> but chris_n++ for his good work so far
10:34:18 <Brooke> indeed
10:34:24 <Brooke> chris_n++
10:34:56 <Brooke> #help someone save Chris from Release Maintainer
10:35:05 <chris_n2> ouch
10:35:22 <paul_p_> maybe the best option is to call on the MLs and see if chris_n2 applies again or someone else save him ;-)
10:35:32 <jransom> I vote for chris_n2 (if he wants it) - done an amazing job
10:35:34 <chris_n2> as I say, if no one steps up before release date I'll do it again
10:35:34 <Brooke> I've naught for this under Module Maintainers
10:35:46 <Brooke> listen to Chris Christie darn it.
10:35:55 <paul_p_> wonderful chris_n2 !
10:36:13 <Brooke> Err Nighswonger. *duck*
10:36:23 * chris_n2 is trying to script it up anyway
10:36:29 <magnuse> chris_n++
10:36:38 <jransom> yay
10:37:47 <Brooke> Module Maintainers? Bueller?
10:37:58 <kf> bueller?
10:38:00 <paul_p_> Bueller ???
10:38:26 <kf> I think revisiting the current module maintainers might be good
10:38:31 <kf> not all are active in the community now
10:38:46 <kf> but perhaps we should do that at a separate meeting
10:38:52 <paul_p_> kf, you mean default assignee on bugzilla ?
10:38:59 <magnuse> kf: +1
10:39:28 <kf> paul_p_: yes, the defaults on bugzilla - we can still vote on the other suggestion
10:39:40 <paul_p_> kf, it's also on the agenda, (misc section)
10:40:00 <slef> #link http://bugs.koha-community.org/bugzilla3/describecomponents.cgi?product=Koha
10:40:35 <slef> Kyle M Hall looks like the only default assignee I've not seen recently
10:40:54 <kf> yes, but he has more than one module
10:41:06 <slef> Circulation and Patrons
10:41:10 <chris_n2> I think koha-devel@lists.koha-community.org is a good idea
10:41:14 <kf> both very important
10:41:19 <Brooke> I'm thinking that Ian might be inclined to pick those up
10:41:19 <chris_n2> maybe not as the default, but as an option
10:41:28 <kf> +1 for optional
10:41:30 <Brooke> but I can hardly predict that with accuracy
10:41:42 <paul_p_> we're not on this part of this agenda !
10:41:46 <chris_n2> then the default assignee could set those bugs they do not intend to work on to the other
10:41:49 <Brooke> #idea trawl koha-devel for options
10:41:51 <kf> wizzyrea would be good for circ - it's not about fixing, more like overseeing, right?
10:41:52 <paul_p_> we arevoting for roles ;-)
10:42:03 <slef> ok, shall I mail him and ask if that's OK? If no response in a week, we call for new
10:42:03 <Brooke> we are talking about roles paul
10:42:05 <chris_n2> ouch
10:42:13 * chris_n2 apologizes to the chair
10:42:20 <kf> perhaps we need to clarify the role a module maintainer has
10:42:33 <sekjal> ^^
10:42:39 <kf> and go through the modules at a separate meeting
10:42:42 <paul_p_> for me module maintainer is a help for RMaint
10:42:43 <kf> to move forward tonight
10:43:03 <paul_p_> responsible for a sub-part of koha maintainance. But we have no candidates, so...
10:43:17 <sekjal> responsible in what sense?
10:43:35 <Brooke> yee haw the devil is up
10:43:36 <sekjal> for creating fixes?  for testing incoming? for overall planning?
10:43:44 <paul_p_> helper for RMaint. testing/applying patches for a given module for example
10:44:06 * chris_n2 must excuse himself and get ready to head to work
10:45:17 <sekjal> would ModuleMaints have any particular privileges?  a weightier signoff?  QA passing?  ability to commit code to a Koha branch?
10:45:19 <Brooke> so what is the community's pleasure?
10:45:43 <kf> I think keeping things in order, like a bug wrangler does
10:45:56 <rangi> how about calling them module champions
10:46:14 <rangi> and making it there role to care about making sure bugs in that area get fixed
10:46:17 <paul_p_> rangi, why not
10:46:24 <paul_p_> yes, that's my idea !
10:46:25 <rangi> their
10:46:40 <kf> which does not mean fixing themselves
10:46:43 <kf> necessarily
10:46:45 <kf> right?
10:46:49 <rangi> so no extra power, except the power to cajole, bribe, threaten
10:46:50 <paul_p_> right (imo)
10:46:55 <rangi> i agree
10:46:57 <rangi> just caring
10:46:57 <kf> because it's too much expecting that
10:46:58 <sekjal> an advocate for a module
10:47:02 <rangi> yup
10:47:02 <kf> more a coordinating role
10:47:18 <kf> make people talk to each other
10:47:27 <sekjal> I nominate wizzyrea for one or more modules, then
10:47:48 <paul_p_> well, in fact, she already is a "module champion" ;-)
10:47:57 <Brooke> #idea Module Champions hold no extra power save to cajole, bribe, and threaten
10:48:01 <slef> wizzyrea already has the websites module which is a bottomless pit. Is wizzyrea here?
10:48:07 <paul_p_> I think she's just lacking the name & badge ;-)
10:48:35 <paul_p_> (some of us will soon look like USSR generals, with 80 medals :D )
10:48:47 <magnuse> hehe
10:49:27 <rangi> we should email the list nominating people
10:49:33 <rangi> and if they dont say no fast enough
10:49:36 <rangi> they get the job
10:49:40 <rangi> :)
10:49:51 <kf> +1
10:49:52 <Brooke> #idea send to the list nominating Champions and if their reaction time is low the trap shuts.
10:49:58 <jransom> it would sort out who was payng attention
10:50:01 <thd> Even when I have had no other time for Koha, I have been fixing the wiki.
10:50:50 <Brooke> on we go
10:51:01 <Brooke> Assistant QA Managers
10:51:20 <Brooke> we've Marcel de Rooy and Jonathan Druart on the slate
10:51:24 <paul_p_> having 2 doesn't harm at all. so I vote +1 for both of them
10:51:31 <Brooke> I believe it was said that it's okay for 2, yes Ian?
10:51:32 <magnuse> +1 for both
10:51:47 <thd> +1 many many volunteers
10:51:50 <slef> +1
10:51:55 <christophe_c> +1 too
10:51:59 <ColinC> +1 for both
10:52:12 <ropuch> +1
10:52:12 <jransom> me too
10:52:25 <kf> +1
10:52:35 <hdl> °1
10:52:51 <sekjal> the more the merrier
10:52:59 <Brooke> #agreed both Marcel de Rooy and Jonathan Druart will be Assistant QA managers
10:53:11 <Brooke> QA Manager is solely Ian
10:53:19 <kf> +1
10:53:20 <magnuse> +1
10:53:28 <thd> +1
10:54:31 <Brooke> Ian is too slow to escape so
10:54:42 <Brooke> #agreed Ian Walls continues as QA Manager
10:54:56 <Brooke> Bug Wranglers we've KF and Magnuse
10:55:07 <Brooke> anyone else got a hankerin' to keep doggies movin?
10:55:28 <magnuse> +1 for kf
10:55:33 <thd> +1 everyone who shows up
10:55:34 <kf> +1 for magnuse
10:55:42 <jransom> +1 +1
10:55:42 <rangi> +2 (one each)
10:55:50 <sekjal> +1 for kf, +1 for magnuse
10:55:56 <ColinC> +1 both
10:56:02 <paul_p_> +1 for magnuse & +1 for kf
10:56:14 <hdl> +1
10:56:18 <hdl> +1
10:56:41 * oleonard +1s kf, magnuse, and everyone he missed before
10:57:09 <paul_p_> I think oleonard could also be elected, as he is BW, even if he don't has the role officially ;-)
10:57:11 <ropuch> +1
10:57:24 <kf> true
10:57:29 <kf> oleonard: up to get a title?
10:57:31 <Brooke> I'm gluing together Documentation Manager and Documentation of DB since they are the same highly competent individual, not that I'm biased ;)
10:58:04 <Brooke> #agreed Bug Wranglers are KF and Magnus (not that this is limited.)
10:58:06 * oleonard would be glad to wear that badge
10:58:07 <christophe_c> +1 for both
10:58:18 <Brooke> #agreed and Oleonard wrangles too :D
10:58:19 <magnuse> +1 for oleonard
10:58:24 <kf> +1 for oleonard :)
10:58:27 <paul_p_> +1 for oleonard
10:58:32 <slef> +1
10:58:39 <rangi> i was gonna make oleonard a champion
10:58:46 <rangi> but he can do both :)
10:58:55 <kf> not so many people, we will get some doubling up :)
10:59:05 <Brooke> kf++
10:59:10 <thd> +1 everyone who shows up again
10:59:29 <Brooke> Nicole for Documentation for life?
10:59:39 <kf> one release at at time
11:00:11 <thd> +1 next couple of releases at a time
11:00:14 <paul_p_> +1 for nicole (maybe not for life)
11:00:18 <Brooke> oh fine, nengard for Documentation for this go
11:00:22 <magnuse> +1
11:00:26 <oleonard> +1
11:00:28 <ColinC> +1
11:00:35 <sekjal> +1
11:00:40 <kf> +1
11:00:41 <rangi> +1
11:01:00 <jransom> +1
11:01:03 <paul_p_> Brooke, i promise i'll never apply as doc manager, or you'll have to learn me too many things :D
11:01:12 <Brooke> ha!
11:01:30 <paul_p_> (too many things in english I mean)
11:01:40 <paul_p_> (for those who don't understand = private joke)
11:01:44 <Brooke> #agreed Nicole Engard is Documentation Manager and Documenter of DB
11:02:36 <Brooke> Frédéric Demians for Translation manager
11:03:11 <thd> +1
11:03:15 <magnuse> +1
11:03:42 <ColinC> +1
11:03:45 <paul_p_> +1
11:03:46 <ropuch> +1
11:03:47 <rangi> fredericd: did you have an idea that kf might help out with translations also?
11:04:04 <fredericd> I've asked to associate cait to this role (or magnuse or both)
11:04:05 <paul_p_> ( & +10 for the idea to remove translation from git repo !)
11:04:28 <fredericd> in order to premare the transmission of this role to one of them
11:04:35 <christophe_c> +1
11:04:47 <rangi> +1 to either of them (or both)
11:05:01 <paul_p_> hehe... good idea. you shouldn't have said it, they'll refuse to help you;-)
11:05:02 <kf> +1 fpr fredericd as translation manager
11:05:12 <magnuse> hm, i won't have time to do something like that in the foreseeable future...
11:05:19 <rangi> kf it is
11:05:27 <magnuse> +1 for kf ;-)
11:05:33 <fredericd> magnuse: you can co-host...
11:05:34 <kf> that's ok for me
11:05:42 <kf> translation is important for us
11:05:51 <paul_p_> if it's OK for you, then +1
11:06:30 <jcamins> #info jcamins = Jared Camins-Esakov, C & P Bibliography Services.
11:06:35 <fredericd> when could you scheduled that: http://wiki.koha-community.org/wiki/Git_Splitting_and_Shrinking
11:06:49 <Brooke> #agreed Frédéric Demians is the Translation Manager with cait assisting.
11:07:46 <christophe_c> +1 fo kf too
11:07:49 <Brooke> release manager Paul Poulain
11:09:33 <magnuse> +1
11:10:09 <magnuse> should we do the whole timebased releases, which features are required for calling it 4.0 discussion again? ;-)
11:10:10 <thd> paul_p_ Do I understand that correctly that your plan for 4.0 will be whatever the collective community plan is?
11:10:36 <kf> I think that's an important point
11:11:13 <Brooke> I think they're both key
11:11:22 <Brooke> and we have been quick for us so far.
11:11:36 <sekjal> I don't believe it's reasonable to schedule feature releases on a timetable
11:11:56 <sekjal> we tried that before with 3.2, and it.... didn't work so well
11:12:13 <paul_p_> sekjal, and my -late- answer to this concern does fix your question ?
11:12:16 <paul_p_> or no ?
11:12:34 <paul_p_> of course i'm for time based releases ! i was the 1st to use the term !
11:12:38 <sekjal> I still hold that timebased releases on the 3.X line are the way to go, with a feature-based 4.0 being released when all its parts are actually ready
11:12:49 <slef> -1 no role appointments for 4.0 yet, especially without any details.
11:12:57 <magnuse> sekjal: +1
11:13:00 <Brooke> I concur slef
11:13:15 * oleonard too
11:13:22 <sekjal> hopefully, all the stuff we plan for in 1 year will be ready in 1 year
11:13:31 <sekjal> and we can jump right from 3.8 to 4.0
11:13:35 <Brooke> I appreciate the idea of parallel development, but perhaps when we have two like releases: either two feature based or two time based.
11:13:43 <paul_p_> maybe I haven't be clear enough in my today mail.
11:13:43 <kf> hm perhaps say, when it's ready, do a 4.0, and aim for that
11:13:46 <kf> when not - do a 3.01
11:13:50 <kf> 3.10
11:13:56 <kf> but don't force features that are not ready
11:13:57 <paul_p_> I think it's just a numbering question, that is really a minor question
11:14:06 <slef> paul_p_: what late answer? http://wiki.koha-community.org/wiki/Proposal_paul_p_RM38 is unchanged since last meeting.
11:14:18 <paul_p_> slef, right, couldn't find time
11:14:34 <sekjal> paul_p_: it's not just numbering, it's feature-based v. time-based
11:14:53 <thd> slef: On the koha-devel list paul_p_ tried to answer sekjal.
11:15:06 <paul_p_> sekjal, no ! definetly no ! (at least in my mind, seems I can't explain clearly my idea)
11:15:33 <slef> thd: got message-id or link handly?
11:15:46 <sekjal> paul_p_:  what if the Solr work cannot pass QA by Oct. 22nd, 2012, for whatever reason?
11:15:59 <sekjal> would you propose delaying 4.0, or not including Solr?
11:16:04 <paul_p_> then no Solr in oct 12 !
11:16:13 <sekjal> ok
11:17:00 <thd> sekjal: So the issue may be merely whether the ready features merit the major version number.
11:17:11 <sekjal> would the release then still be called Koha 4.0, if the major structural change isn't ready, or would it go to 3.10?
11:17:24 <paul_p_> sekjal, 3.10
11:17:47 <paul_p_> 1st digit is updated on any major structural change being the rule
11:17:59 <paul_p_> I won't call it 4 just to beat chrome numbering ;-)
11:18:06 <paul_p_> I won't call it 4 just to beat chrome numbering speed ;-)
11:18:14 <sekjal> paul_p_:  okay, so then you and I are mostly in agreement.
11:18:20 <thd> slef: today in koha-devel.
11:18:21 <paul_p_> sekjal, I think too
11:18:45 <jransom> so we preomise a releasae and whats ready is in it
11:18:56 <magnuse> slef: http://lists.koha-community.org/pipermail/koha-devel/2011-October/date.html
11:19:05 <slef> magnuse: ta
11:19:20 <sekjal> I'd like the opportunity to see if any other major features can be reasonably developed in time for our target 4.0 date, but that's really details as far as I'm concerned
11:19:29 <slef> http://lists.koha-community.org/pipermail/koha-devel/2011-October/036235.html
11:20:03 * oleonard must leave, is ready to give paul_p his vote knowing that it will All Work Out.
11:20:10 <kf> on another question: can we discuss lowering the qa barrier for some time? I don't feel so comfortable with that, even if it's only for a limited amount of time
11:20:25 <sekjal> ^^
11:21:06 <paul_p_> kf, I think i've already said i've abandonned the idea, as it seems ppl are against it.
11:21:11 <rangi> #info stick with time based releases, if a release contains a change large enough to warrant a major version number we use it, otherwise keep on the 3.x one
11:21:17 <Brooke> excellent to hear Paul
11:21:25 <rangi> is that what ppl are concluding?
11:21:28 <kf> paul_p_: with more people doing qa I hope we can catch up on things :)
11:21:37 <sekjal> kf:  that's my hope, too
11:21:50 <jransom> rangi: sounds that way
11:22:09 <paul_p_> that's my hope too, although i'l bug ppl on koha-devel to point pending patches !
11:22:10 <magnuse> rangi: sounds good to me
11:22:13 <thd> +1 paul_p_ sensibly sensing the community
11:22:35 <magnuse> paul_p++
11:23:21 <kf> ok
11:23:24 <christophe_c> +1 paul_p
11:23:26 <kf> ready to vote now?
11:23:43 <Brooke> I think so
11:23:53 <Brooke> any other unresolved issues?
11:24:28 <mtj> morning all
11:24:35 <Brooke> morena
11:24:48 <Brooke> well then go on and vote properly you cats!
11:24:52 <magnuse> +1
11:24:52 <jransom> heya mj
11:24:53 <paul_p_> just one point (already written iirc) = I plan to dedicate half of my time to the RM role
11:25:01 <thd> +1
11:25:04 <slef> -1 no prejudicing the next release's roles
11:25:08 <jransom> +1 for paul
11:25:10 <kf> +1
11:25:10 <mtj> i bumped into eythian, and we got sidetracked at a pub
11:25:15 <christophe_c> +1
11:25:16 <kf> lol
11:25:21 <rangi> heh
11:25:40 <kf> celebrating your new roles I guess - because you got the jobs
11:25:46 <mtj> ... just got back home, and remembered the irc meeting
11:25:56 <slef> mtj: point of info, your examples git is Server Temporarily Unavailable every time I tried so far
11:26:15 <thd> paul_p_ Is half time enough time?
11:26:31 <rangi> +1
11:27:04 <mtj> slef, will fix that now
11:27:13 <sekjal> +1 for paul for 3.8 RM
11:27:14 <paul_p_> enough I don't know. I can't afford doing more, and promise not doing less
11:27:32 <Brooke> #agreed Paul Poulain is the release manager.
11:27:34 <paul_p_> enough I don't know. I can't promise doing more, and promise not doing less
11:27:43 <thd> paul_p_++
11:27:47 <paul_p_> (maybe i'll be able to do more, but i'm not sure at all)
11:28:09 <Brooke> #topic KohaCon2011
11:28:39 <Brooke> no other Indians in the house.
11:28:42 <rangi> just fyi, i did on average about halftime of my working time
11:28:54 <jransom> 16 more sleeps for me
11:28:55 <rangi> and 3 or 4 hours of my own time each day
11:29:24 <rangi> its pretty much a fulltime job, but the realities are, you have to do probably about half unpaid
11:29:30 <thd> rangi: That is good to know as a comparison for such an all consuming job.
11:29:33 <jransom> its aery big commitment
11:29:50 <rangi> it comes and goes too
11:29:55 <jransom> kudos to those who take it on
11:29:56 <rangi> lumpy
11:30:16 <thd> rangi: lumpy?
11:30:26 <Brooke> fits and spurts
11:30:33 <thd> :)
11:30:34 <rangi> thd: not steady amount, big lumps, then quiet
11:31:22 <paul_p_> I hope that the lot of work time will occur whent i'm "low work needed" on managing my company
11:31:23 <Brooke> so
11:31:34 <Brooke> we've no one to address anything anyway on to
11:31:41 <Brooke> #topic KohaCon 2012
11:31:48 <Brooke> Congratulations Scotland :D
11:31:58 <magnuse> woohoo!
11:32:05 <kf> whooohoooooo!
11:32:18 <kf> slef++ coop++ (?)
11:32:20 <jcamins> Yippee!
11:32:22 <thd> slef: How do you propose choosing a time?
11:32:38 <kf> I think having it earlier next year was discussed - I like the idea
11:32:43 <rangi> och aye the noo (and yes i know no one actually says that in scotland .., at least not as a phrase like that)
11:32:51 <slef> thd: Unless there's a strong reason not to, we will got with best availability and weather, probably June.
11:32:53 <Brooke> he chooses the one that's convenient to him as host.
11:32:59 <jransom> yay - i nve never been toscotland and my great grandads were scottish and irish andfrench and english
11:32:59 <jcamins> rangi: you'd be surprised.
11:33:05 <kf> I think the host decides
11:33:16 <kf> trying not to make it the same time as other important things
11:33:49 <slef> kf: yes, there are many festivals in Edinburgh which we cannot outbid for venues and so on.
11:33:50 <jransom> but not sure i'll be able to swing 2 trips in same financial year
11:34:01 <paul_p_> Brooke, some details about the votes ?
11:34:08 <slef> jransom: when is your financial year break?
11:34:16 <sekjal> slef:  just so long as it's not late October; missing 3 Halloween's in a row is too much for my family!
11:34:16 <Brooke> paul ask nengard for good numbers there's a link here
11:34:23 <Brooke> we can make it public I suppose yes nicole?
11:34:26 <thd> jransom: Change your financial calendar to suit.
11:34:26 <wahanui> thd: that doesn't look right
11:34:29 <jransom> 30 june - but thats not a reason to influence date choice
11:34:46 <nengard> Brooke you want to remove the names and such before making it public
11:34:51 <nengard> keep it anonymous
11:34:59 <nengard> before putting it on the wiki
11:35:02 <nengard> like last year
11:35:13 <Brooke> arright good point
11:35:23 <kf> yes, important point
11:35:28 <kf> people have not agreed to make the data public
11:35:35 <slef> #info I thank all voters and koha-community on behalf of the co-op. We'll get moving and be in touch.
11:35:45 <rangi> coolio
11:35:51 <nengard> #info Nicole Engard, ByWater Solutions, Documentation Manager
11:35:54 <jransom> i'm going to head off folks - see some of yuou in Mumbai and maybe the rest in Scotland!
11:36:00 <Brooke> #topic Global Bug Squashing Days
11:36:07 <jransom> congrats slef
11:36:35 <rangi> they rule
11:36:46 <rangi> thats my input on the subject
11:36:52 <magnuse> there is a gbsd on this coming friday, as a last sprint to the string freeze http://wiki.koha-community.org/wiki/2011-10-07_Global_bug_squashing_day
11:36:57 <magnuse> be there or be []
11:37:00 <paul_p_> hi nengard. Do you have some details about KohaCon12 vote ?
11:37:06 <paul_p_> (number of votes, % ...)
11:37:15 <jcamins> magnuse: why are they always on Fridays?
11:37:30 <paul_p_> magnuse: this time all BibLibre will join GBSD for all the day.
11:37:31 <kf> because fridays are for fun things? :)
11:37:37 <kf> biblibre++
11:37:45 <magnuse> jcamins: initally because biblibre have their community days on fridays, but it cn be changed, of course
11:37:51 <nengard> 88 votes
11:37:58 <magnuse> biblibre++
11:38:11 <nengard> 74 voted for Edinburgh as the first choice
11:38:12 <jcamins> magnuse: ah. I have no objection to keeping them on Fridays for now, I was just wondering.
11:38:13 <slef> this GBSD is far enough into a month I may be able to take part... if my colleagues get moving with the month-start admin today/tomorrow
11:38:16 <kf> nice!
11:38:24 <nengard> 12 voted for Reno as #1
11:38:29 <nengard> 2 didn't complete the vote
11:38:36 <paul_p_> (magnuse and that will be the case for all GBSD : we concluded that half a day every 2 week was not the best, because when you've half a day, you need to start and ... it's done. So we switch 1 day every month, the GBSD)
11:38:57 <nengard> 7 voted for Edinburgh for #2 and 58 for Reno as #2 and 23 didn't rank a #2
11:39:06 <magnuse> paul_p_: great!!
11:39:20 <Brooke> not that bugs need to wait for a GBSD :)
11:39:28 <magnuse> Brooke: agreed!
11:39:29 <Brooke> anything else on bugs?
11:39:32 <jwagner> #info Jane Wagner, PTFS/LibLime
11:39:38 <magnuse> not from me
11:40:18 <Brooke> #topic Old Business
11:40:25 <magnuse> (other than to say having gbsd as a regular thing on the agenda might be unnecessary...)
11:40:29 <Brooke> did we have any actions from last meeting that neet to be seen to?
11:40:59 <magnuse> not accoring to http://librarypolice.com/koha-meetings/2011/koha.2011-09-07-18.00.html
11:41:04 <mtj> so,
11:41:06 <rangi> nope
11:41:12 <mtj> oops..
11:41:19 <Brooke> #topic Misc
11:41:41 <Brooke> follow up on the koha-devel thread for bugzilla and default assignee
11:42:30 <Brooke> someone want to talk about this? is this summat that will be covered by Champions or is it different?
11:43:00 <paul_p_> I think it differs, but not sure i'm right.
11:43:46 <paul_p_> i've had 2 ideas : having koha-devel as default assignee & using NEW/ASSIGNED status to deal with real assignee
11:44:01 <kf> I thought we do that
11:44:09 <kf> as long as something is NEW noone is workign on it
11:44:19 <paul_p_> the big point being: "how to detect abandonned bugs ?"
11:44:20 <slef> kf: I think koha-qa is default assignee isn't it?
11:44:28 <kf> no
11:44:29 <paul_p_> slef, yep
11:44:30 <jcamins> I don't think koha-devel is such a good idea. That would greatly increase the volume of e-mail.
11:44:31 <kf> module maintainer is
11:44:35 <kf> and cc bug list
11:44:40 <slef> #link http://bugs.koha-community.org/bugzilla3/describecomponents.cgi?product=Koha
11:44:43 <paul_p_> kf, slef said koha-QA
11:44:45 <paul_p_> not assignee
11:45:02 <kf> phone call
11:45:15 <paul_p_> maybe we could have no default QA and have koha-qa as default assignee
11:45:16 <paul_p_> ?
11:45:16 <slef> no, kf was right - I was wrong. module maint is default assignee
11:45:35 <slef> paul_p_: abandoned bug = Last change > N months ago?
11:45:56 <paul_p_> oups, sorry I misunderstand you. We have 2 things : default assignee & default QA
11:46:09 <paul_p_> default assignee being someone & default QA being koha-QA mailing list
11:46:51 <paul_p_> idea : use koha-qa as default assignee & let QA contactbeing set by QA manager & assistants ?
11:47:05 <slef> I don't like that. QA have enough to do already.
11:47:29 <slef> I don't understand what problem you are trying to solve here. I'm currently searching koha-devel for the thread. A link in the agenda would have been helpful.
11:48:46 <sekjal> I mostly use RSS for QA notifications
11:48:51 <paul_p_> the question I try to solve : how to detect non endorsed bugs & how to avoid having useless default assignees
11:49:03 <thd> slef: The issue was raised on the koha-devel list in August.
11:49:14 <slef> thd: ok... I'd not got back that far yet. Thanks.
11:49:29 <slef> #link http://lists.koha-community.org/pipermail/koha-devel/2011-August/035984.html
11:50:20 <slef> I mean, the answer to paul_p_'s question in that post seems simple: assign such a bug to QA. I don't see why defaults need change to do that.
11:50:40 <slef> or actually, RESOLVE WONTFIX
11:50:55 <paul_p_> slef, assign such a but to QA = you mean "QA mailing list" ?
11:51:21 <slef> paul_p_: koha-bugs@lists.koha-community.org
11:51:52 <paul_p_> slef, but if it's a real bug, I won't set "RESOLVE WONTFIX" !!! it's just that I want to say "ok, it's still here, but it's not for me"
11:52:22 <paul_p_> assigning to koha-bugs what a given default assignee don't want to endorse sounds a good idea
11:52:25 <slef> I think a default assignment of TEAM (Toll! Ein Anderes Macht's! = Great, someone else will do it!) is an awful idea and I don't see how it addresses your problem.
11:52:47 <slef> But for explicitly disowning bugs, OK.
11:53:03 <paul_p_> slef, well, atm, everybody think "paul will take care", but I won't
11:53:18 <paul_p_> good, we agree on that !
11:53:28 <slef> paul_p_: but you think it should be fixed, just not by you?
11:53:36 <paul_p_> yep
11:54:09 <thd> slef: What should happen after bugs are explicitly disowned?  What action should be triggered?
11:54:10 <Brooke> maybe we can feature them for adoption at GBSDs.
11:54:23 <slef> #link http://bugs.koha-community.org/bugzilla3/buglist.cgi?field0-0-0=days_elapsed&query_format=advanced&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&type0-0-0=greaterthan&value0-0-0=90
11:54:32 <paul_p_> thd, have someone else endorsing it
11:54:40 <slef> #info ^^ bugs that are unchanged more than 90 days
11:54:55 <slef> #info change the 90 on the end for a different number of bugs
11:55:31 <paul_p_> (many have patch pushed, maybe we could remove them)
11:55:52 <Brooke> let's mull this over more mebbe?
11:56:05 <paul_p_> Brooke, ???
11:56:05 <wahanui> somebody said Brooke, was it summer now in NZ?
11:56:18 <Brooke> wahanui forget brooke
11:56:18 <wahanui> Brooke: I forgot brooke
11:56:21 <slef> thd: QA or anyone watching koha-bugs to review/move it on when they get time. Could put a list of bugs in a call for help in newsletter or koha-devel mail. Lots of ideas.
11:56:46 <Brooke> #idea list of bugs in a call for help or koha-devel mail
11:57:07 <Brooke> #help think over the handling of bugs with no endorsement.
11:58:00 <Brooke> #topic Gamification
11:58:19 <Brooke> I wanted to draw attention to
11:58:27 <Brooke> http://dmlcompetition.net/
11:58:39 <wizzyrea> #info Liz Rea (NEKLS - apologies on the tardiness)
11:58:46 <Brooke> some Gamification achievement stuff was already proposed on the wiki
11:59:13 <Brooke> http://wiki.koha-community.org/wiki/Gamifying_the_ILS
11:59:27 <Brooke> the proposals they're looking for run very close to the achievement stuff outlined
11:59:30 <Brooke> the bad news is
11:59:35 <Brooke> they're do very soon
11:59:40 <Brooke> (like 15th October)
11:59:41 <Brooke> so
11:59:46 <Brooke> here's what I have in my crazy head
11:59:56 <Brooke> submit summat
12:00:00 <Brooke> if they like it, then great
12:00:05 <Brooke> it's not actual coding
12:00:10 <Brooke> so I'm up for it
12:00:16 <wizzyrea> go for it
12:00:31 <Brooke> if they don't like it
12:00:38 <Brooke> we have a nice armature for the stuff we were gonna do anyway
12:00:42 <Brooke> at least in one department.
12:01:29 <magnuse> what's not to like? ;-)
12:01:31 <mtj> http://git.kohaaloha.com/?p=koha-perltidy/.git;a=commit is back up?
12:01:48 <magnuse> mtj: works for me!
12:01:54 <Brooke> k I shall take thy silence as a sign of assent.
12:02:09 <wizzyrea> yes, i'll help you
12:02:16 <thd> Brooke: I see a strategy for gaming the library for achievement which would abuse the circulation desk.
12:02:21 <kf> back
12:02:37 <paul_p_> Brooke, I keep silent because i've nothing to say (& i'm having lunch, i admit ;-) )
12:02:43 <mtj> magnuse: ta :)
12:03:01 <wizzyrea> thd: the features are completely optional
12:03:05 * rangi has to go to sleep
12:03:10 <magnuse> Brooke: do it on the wiki and we can all chime in if we see fit?
12:03:21 <Brooke> will put it there when I've got summat
12:03:27 <magnuse> yay
12:03:31 <Brooke> excellent idea.
12:03:41 <thd> Brooke: Yes, I understand that those are ideas for scoring points and not rules.
12:04:28 <Brooke> #topic coding guidelines
12:04:32 * thd caused a stack overflow in the circulation system.   High score :)
12:04:46 <wizzyrea> not that kind ofachievement
12:04:48 <Brooke> (last point in the agenda before setting the time and date! Woot!)
12:05:06 <Brooke> take it away mtj, methinks
12:05:13 <thd> The examples of perl tidy in action are down.
12:05:48 <mtj> thd: but are now back up?
12:07:00 <mtj> but regardless of my examples.... lets vote :)
12:07:06 <slef> mtj: could you paste how many lines are changed (I think it's in the whatchanged output?)
12:08:10 <mtj> slef: i dont know how to do that...
12:08:23 <slef> mtj: git whatchanged -1 # IIRC
12:08:30 <mtj> hmm, 1 tic...
12:08:39 * slef checks that here
12:08:57 <slef> that's not it... 1mo
12:09:26 <kf> I hve no strong opinion about the coding thing - make it consistent and choose one, change code not at once but bit by bit perhaps
12:09:37 <paul_p_> kf++
12:09:43 <wizzyrea> kf++
12:09:47 <ColinC> kf+
12:09:51 <slef> mtj: git format-patch -o .. 'HEAD^'
12:09:57 <wizzyrea> (and publish it somewhere)
12:09:58 <thd> kf++
12:10:05 <kf> oh wow
12:10:08 <kf> :)
12:10:09 <slef> that will show lines like
12:10:09 <slef> filename | 4 ++--
12:10:21 <slef> paste those lines
12:10:27 <kf> yep, important, document it, make it easy to find
12:10:30 <kf> and easy to use
12:10:32 <slef> from near the start of the patch file
12:10:35 <paul_p_> My 2nd concern being : don't spend time reinventing the wheel, spend time hacking
12:10:48 <kf> choose an existnig style, not create one
12:10:51 * magnuse agrees with kf
12:10:59 <ColinC> Agreed
12:11:00 <thd> mtj: I think that consistency within each file is sufficient.
12:11:02 <Brooke> believe perltidy is what's on the table, yes/
12:11:04 <paul_p_> kf, yep, that's what I meaned ;-)
12:11:28 <slef> ok, let me explain my concern
12:11:50 <slef> the perltidyrc (koha-style in mtj's examples) was an attempt to standardise what was already happening
12:12:18 <slef> if we switch to another style, it may be a big disruption for little gain
12:12:35 <slef> but it may be that no-one was using the perltidyrc any more anyway, so that will also be a disruption
12:12:51 <slef> in which case we might as well pick anything except pbp.
12:12:52 <paul_p_> good point (except i'm not sur all the script already have "koha-style")
12:13:16 <paul_p_> why "except pbp" ?
12:13:17 <slef> paul_p_: do biblibre still code to 178-char line length?
12:13:28 <mtj> http://git.kohaaloha.com/?p=koha-perltidy/.git;a=blob;f=0001-applied-various-perltidy-styles-to-Circ.pm.patch;h=d4d6ee5d575f289d1f279757007eb7b5c6f0ab10;hb=95002157c25c04e104631bfc127fcec56e825cf3
12:13:28 <thd> :)
12:13:37 <slef> pbp is not documented in FOSS anywhere as far as I can tell.
12:13:38 <paul_p_> slef, dunno, we don't have an explicit rule
12:14:00 <mtj> slef:  so koha-style has the least change from current
12:14:05 <slef> 12 Circulation.pm.gnu-style       | 1730 +++++++++++++++++-----------------
12:14:05 <slef> 
12:14:05 <slef> 13  Circulation.pm.koha-style      | 1673 +++++++++++++++++----------------
12:14:05 <slef> 
12:14:08 <slef> 14  Circulation.pm.pbp-style       | 2037 +++++++++++++++++++++++-----------------
12:14:11 <slef> 
12:14:14 <slef> 15  Circulation.pm.perlstyle-style | 2045 +++++++++++++++++++++++-----------------
12:14:18 <slef> 
12:14:21 <slef> mtj++
12:14:31 <magnuse> mtj++
12:14:43 <slef> mtj: but all are bigger than I thought, so probably no-one uses koha-style explicitly either
12:15:10 <ColinC> I think at present no style is in operation
12:15:16 <paul_p_> I think so
12:15:19 * wizzyrea suspects there was not enough suggesting that people should use it, lately
12:15:47 <slef> for comparison, Circulation.pm is about 3000 lines
12:16:04 <jcamins> FWIW, I have no idea how one would go about using this.
12:16:05 <mtj> slef, yep 'koha-style' perltidy is not really offiical, so not enforced
12:16:33 <mtj> ok, so shall we vote on this issue?
12:16:41 * magnuse has been following koha rather closely for 3 odd years, and can't remember seeing anything about any explicit coding styles...
12:17:04 <slef> jcamins: run perltidy OPTIONS FILENAMES before commit.
12:17:11 <mtj> magnuse: yes and yes
12:17:14 <jcamins> slef: that should be documented somewhere.
12:17:26 <slef> jcamins: will do if I'm correct ;-)
12:17:52 <slef> jcamins: also we could probably put vim and emacs tags into the files to trigger smart editors to adapt
12:17:54 <thd> slef: Is the actual practise of continuing to not have an official style an option we are considering?
12:18:14 <slef> thd: we could consider it but I wouldn't advocate it strongly.
12:18:46 <paul_p_> thd, I would prefer to have a rule !
12:18:48 <slef> perlstyle-style and pbp-style are so close in disruptiveness, I'd really prefer we pick the more FOSS perlstyle-style
12:19:06 <jwagner> Are you proposing to reject patches that aren't written to style?
12:19:21 <jwagner> Or have the QA person change them?
12:19:42 <ColinC> I'd agree with slef I think use defaults is easier than suggesting people use exceptions
12:19:44 <slef> I don't think transition has been discussed at all yet, has it?
12:19:59 <paul_p_> other option (dunno if it's a good one), have a big patch at the beginning of 3.8
12:20:06 <Brooke> it was over the mailing list slef
12:20:06 <paul_p_> updating all scripts
12:20:12 <Brooke> and I think it was in the way back, too
12:20:22 * paul_p_ think it's not a good idea in fact...
12:20:25 <slef> Brooke: not policy though?
12:20:29 <ColinC> I suggest we start first with a recommendation that people use it
12:20:31 <mtj> jwagner: lets cross that very distant bridge *after* we decide on an offiical style
12:20:33 <Brooke> we're trying to make it policy, yes?
12:20:46 <slef> I'd vote: gnu > perlstyle > koha > no-style > pbp # though
12:20:53 <jwagner> mtj, but part of the policy has to be enforcement of some kind, doesn't it?
12:21:00 <slef> Brooke: recommendation not requirement first I think.
12:21:11 <Brooke> aye naught wrong with a strong suggestion
12:21:23 <thd> paul_p: I remember a discussion at Koha-Con 2009 where gmcharlt seemed to wisely state something to the effect of not forcing people to use any one style of indentation etc. avoided unnecessary religious strife.  Consistency within the file is more important.
12:21:44 <slef> get the documentation sorted, get most of us using it and then we can look at a requirement. Viva Do-ocracy!
12:21:51 <sekjal> I'd prefer not to spend QA time reformatting style: it would be better if it were up to the individual developer to make any fixes necessary
12:22:06 <paul_p_> thd, not sure I agree with this idea. That's important to have consistency over coding style !
12:22:15 <paul_p_> Koha is hard enough to hack already !!!
12:22:39 <mtj> ok, a vote on whether to use an offical perltidy style , please?
12:22:40 <Brooke> how about we recommend that developers use perlstyle
12:22:43 <jwagner> I'm not really understanding why it's a problem.  Consistency would be nice, but it is a crisis?
12:22:49 <Brooke> or what mtj said
12:22:55 <Brooke> cause he's more knowledgeable
12:22:55 <ColinC> we should give some doc on how to use the tool
12:22:59 <mtj> surely no-one disagrees on this basic point?!?
12:23:06 <Brooke> jwagner: it will be if we continue not to act
12:23:07 <paul_p_> sekjal, OK. But if I submit a patch of, say 40 lines, how can I perltidy those 40 lines only ? Should I send a patch updating all the script ?
12:23:37 <thd> paul_p_: I agree that consistency is important.  However, how much consistency is important relative to other things.
12:23:45 <ColinC> no you can run it on your changed lines only
12:24:02 <wizzyrea> (and does tidying 40 lines of thousands make it better or worse?)
12:24:04 <thd> paul_p_: Will we be systematically reformatting the entire code base?
12:24:16 <paul_p_> Brooke, there were no rule for 10 years, so jwagner is right to ask. But I think it's good to have consistency though.
12:24:27 <paul_p_> ColinC, how can you run on changed lines only ?
12:24:33 <ColinC> reformatting the entire code base loses history
12:24:38 <paul_p_> thd, that's my question
12:24:54 <paul_p_> ColinC, not history, but make git blame being confused.
12:24:58 <Brooke> not a bad idea once a decade...
12:25:06 <paul_p_> (ie: everything is blamed to the perltidy patch)
12:25:11 <thd> paul_p: Does consistency of indentation matter outside an individual file?
12:25:44 <paul_p_> thd, I would say yes, (but don't ask why ;-) )
12:25:58 <ColinC> paul_p you can filter lines via perltidy easy to do in vim and emacs
12:26:04 <slef> Just a note: I have voteengine working here. I can evaluate a preference vote if you wish, but I'd need to give instructions on how to vote :)
12:27:08 <paul_p_> ColinC, not everybody uses vim or emacs, & we want to lower the barriers !
12:27:17 <slef> I'd also need to tell it a method: Condorcet with IRC, UK Usenet and Schulze seem the most likely, but it might have your favourite.
12:27:33 * oleonard boggles at the long meeting
12:27:44 <Brooke> it's almost over owen
12:27:49 <Brooke> HINT
12:27:53 <Brooke> decide.
12:28:07 * Brooke is subtle like a brick.
12:28:13 <thd> I am a great advocate for consistency, however, I am concerned that systematic use of tidy without any other reason to modify a file will complicate tracing code changes.
12:28:14 <paul_p_> sekjal, anytihng to say ?
12:28:42 <ColinC> thd++
12:28:43 <mtj> ... everyone ready to vote now?
12:28:50 <kf> if we can't come to a decision here
12:28:51 <jwagner> what is the motion on the floor?
12:28:54 <Brooke> propose summat to vote on
12:28:55 <sekjal> sorry, was afk
12:28:55 <slef> I move we take a preference vote for a style now, Condorcet with IRV.
12:28:56 <kf> perhaps we should have a vote
12:28:59 <kf> but make thing smoving
12:29:00 <paul_p_> well, not sure until we don't know the options !
12:29:03 <mtj> pbp++
12:29:05 <kf> don't have no decision
12:29:06 <slef> Figure out transition later.
12:29:38 <paul_p_> slef++ for figuring out transition later
12:29:41 <mtj> options are: pbp, perl-style, gnu/gcs, koha-style
12:29:53 <Brooke> one for pbp if you've got a favourite style please mod it up so we can get out of here
12:30:07 <ColinC> perl-style++
12:30:09 <thd> I am also concerned that indentation styles which do not collapse in vim lead to overly long lines which cannot always be broken across multiple lines.
12:30:09 <wahanui> okay, thd.
12:30:15 <slef> perl-style++
12:30:30 <slef> gnu++
12:30:31 <mtj> ah, and option number 5 is ... no style!!!!!
12:30:39 <slef> (if we're going to do it approvalwise)
12:30:42 <jwagner> no-style++
12:30:53 <mtj> slef:  thats 2 votes love ;)
12:31:07 <Brooke> he called for a preference
12:31:19 <slef> mtj: I'm taking this as an approval vote, seeing as no-one wants a preference vote.
12:31:24 <paul_p_> perl-style++, then pbp
12:31:32 <thd> slef: I still think there is a none of the above missing.
12:31:39 <kf> not no-style ?
12:31:49 <kf> is my vote, don't know enough to compare, but I am all for consistency
12:31:52 <Brooke> thd a bunch have said no style
12:31:54 <oleonard> some-style++, no-style--
12:31:56 <mtj> php, then perl-style for me
12:31:58 <wizzyrea> pick-and-dictate++
12:32:04 <slef> heh, php
12:32:08 <sekjal> I don't particular care what styling we use, so long as 1) it's consistent in each script (so incoming patches follow existing style), and 2) any style-only changes are independently submitted from functionality changes
12:32:12 <thd> Brooke: none of the above would not be no style.
12:32:17 <paul_p_> wizzyrea, lol, but so true !!!
12:32:29 <mtj> slef: oops! :p
12:32:32 <kf> sekjal++
12:32:41 <oleonard> sekjal's point 2 is important considering the trouble whitespace changes cause patch comprehension
12:32:55 <slef> thd: none of the above would be effectively for current practice, which we have to conclude from mtj's great work on the examples is no-style.
12:32:57 <thd> Brooke: none of the above would be a style which we have not yet considered.  Some modified koha style.
12:33:31 <mtj> ok...... anyone else??
12:33:37 <slef> thd: that's another option that no-one has yet proposed. Anyone could have, but I assume it has no advocate.
12:33:37 <thd> no-style yet first
12:33:50 <thd> perl style second
12:34:19 <mtj> if not... could slef calculate the winner, please?
12:34:25 <thd> However, I really do not mean no-style.  I mean some other style.
12:34:37 * kf is confused
12:34:51 <kf> ok, perhaps we have to have a vote about this? using a tool?
12:35:01 <kf> to vote? like for the conference?
12:35:02 <Brooke> that's what we're trying to do kf
12:35:05 <mtj> and the winner is.... ?
12:35:13 <Brooke> ooh cool idea
12:35:16 <kf> but irc might not be the right place
12:35:18 <slef> I think standings are: no-style: kf, jwagner; perlstyle: paul_p_, ColinC, slef; pbp: mtj (+some 2nd prefs); gnu: (some 2nd prefs); koha: no-one
12:35:20 <Brooke> if we come up with a survey for it
12:35:23 <slef> have I missed anyone?
12:35:24 <kf> slef: wrong
12:35:36 <slef> kf: how?
12:35:36 <kf> not no-style - I agree with any style as long it's consistent
12:35:43 <kf> sorry for causing confusion
12:35:46 <slef> ok, so oleonard and kf are any-style
12:35:50 <kf> yep
12:35:53 <slef> as is sekjal I think
12:36:06 <slef> any more mistakes/omissions?
12:36:23 <sekjal> slef:  yes, any style so long as it's consistent is fine by me
12:36:36 <wizzyrea> any-consistent-style++
12:36:43 <mtj> ok, can i change to be perl-style? :p
12:36:43 <jwagner> I'll go with any style if consistent
12:36:47 <Brooke> so then perl style has the most support, yes?
12:36:54 <magnuse> any style so long as it's consistent is fine by me too
12:36:55 <paul_p_> ok, so all of you vote for the option that has the most votes already ;-)
12:36:57 <mtj> making perl-style the winner oMg?!?
12:37:05 <Brooke> #agreed perl-style
12:37:08 <paul_p_> mtj, why omg ?
12:37:10 <mtj> and perl-style it is!!!!!!
12:37:18 <slef> I think standings are: no-style: no-one; perlstyle: paul_p_, ColinC, slef, mtj; pbp: (some 2nd prefs); gnu: (some 2nd prefs); koha: no-one; (any style: oleonard, kf, sekjal, wizzyrea, jwagner)
12:37:23 <slef> naughty no-one, double-voting
12:37:38 <Brooke> #topic time and date of next meeting
12:38:22 <Brooke> how about 16thish Nov?
12:38:28 <Brooke> that way it's after KohaCon?
12:38:40 <slef> is this the 2am UTC one?
12:38:51 <Brooke> given the pattern should be
12:38:58 <paul_p_> slef, yes :(((
12:39:22 <paul_p_> 16th++ for me (not 9th pls, i'll be jet lagged !)
12:39:51 <mtj> paul_p_:  just joking  - i dont mind at all :)
12:39:52 <thd> +1 16th
12:39:59 <slef> yeah, I won't make that. Big co-op planning meeting at 11 UTC, probably including kohacon2012
12:40:08 <slef> but don't let that stop you
12:40:45 <Brooke> barring objections
12:40:55 <Brooke> 16 November 2 UTC
12:41:05 <mtj> paul_p_:  omg - i am happy to reach a decision on this topic, thats all :)
12:41:10 <Brooke> going noce
12:41:14 <Brooke> going twice
12:41:14 <thd> slef: The hours would not conflict but I assume that your sleep would.
12:41:18 <Brooke> going gone
12:41:36 <Brooke> #agreed next meeting 16 November 2 UTC
12:41:42 <Brooke> #endmeeting