18:00:09 <Brooke> #startmeeting
18:00:09 <huginn`> Meeting started Wed Dec  7 18:00:09 2011 UTC.  The chair is Brooke. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:09 <huginn`> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:00:16 <Brooke> #topic Introductions
18:00:29 <Brooke> Welcome, welcome, please introduce yourself using #info
18:00:32 <wizzyrea> #info wizzyrea - Liz Rea - NEKLS
18:00:50 <jcamins> #info jcamins - Jared Camins-Esakov, C & P Bibliography Services, LLC
18:00:51 <thd> #info Thomas Dukleth, Agogme, New York City
18:00:53 <jwagner> #info Jane Wagner, LibLime/PTFS
18:00:59 <cait> #info Katrin Fischer, BSZ, Germany
18:01:17 <drojf> #info mirko tietgen, humboldt-universität zu berlin, germany
18:01:31 <Irma> #info Irma Birchall, CALYX
18:01:36 <mtj2> #info mason.james, nz
18:01:39 <chris_n> #info Chris Nighswonger, FBC
18:01:40 <davidnind> #info David Nind, Wellington, New Zealand
18:02:00 <indradg> #info Indranil Das Gupta, Kolkata, India
18:02:11 <slef> #info MJ Ray, software.coop, Norfolk, England
18:02:24 <jransom> joann ransom hlt NZ
18:02:35 <dpavlin> #info Dobrica Pavlinusic, FFZG, Zagreb, Croatia
18:02:41 <marijana> #info Marijana Glavica, Croatia
18:02:42 * slef hands jransom an #info
18:03:25 <joannR> (can't find hash key yet on my transgformer keyboard - so yeah, thanks0
18:03:26 <trea> #info Thatcher Rea, ByWater Solutions, USA
18:03:49 <slef> joannR: copy-paste one?
18:03:59 <slef> (what's a transgformer?)
18:04:15 <Brooke> Haere Mai let's get this show on the road
18:04:19 <sekjal> #info Ian Walls, ByWater Solutions, Koha 3.8 QAM
18:04:34 <jransom> asus android epad touchscreen thingee
18:04:42 <wizzyrea> (fab tab)
18:04:47 <slef> #link http://wiki.koha-community.org/wiki/General_IRC_Meeting,_7_December_2011
18:04:59 <Brooke> #topic Announcements
18:05:03 <slef> jransom: nice.
18:05:08 * chris_n grumbles about FF crashing
18:05:11 <bag> #info Brendan Gallagher, ByWater Solutions
18:05:45 <Brooke> anyone have any earth shattering announcements?
18:06:08 <chris_n> 3.4.7 is released
18:06:19 <Brooke> hooray
18:06:20 <chris_n> and in the wild
18:06:35 <Brooke> #topic Roadmap to 3.4
18:06:45 <cait> chris_n++
18:06:50 <Brooke> chris_n++ indeed
18:07:18 <chris_n> #info 3.4.7 is released
18:07:45 <chris_n> the plan is to continue releases until applicable patches/commits slow to a trickle
18:07:50 <Brooke> anything else vaguely 3.4 related?
18:08:13 <chris_n> that's all from me
18:08:23 <jenkins_koha> Project Koha_3.6.x build #16: STILL UNSTABLE in 1 h 26 mn: http://jenkins.koha-community.org/job/Koha_3.6.x/16/
18:08:25 <jenkins_koha> * ago: Bug 6971: XSLT Opac Detail displays 245 subfields out of order.
18:08:25 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=6971 minor, PATCH-Sent, ---, ago, ASSIGNED , XSLT Opac Detail displays 245 subfields out of order
18:08:26 <jenkins_koha> * jcamins: Bug 6971: XSLT Intranet Detail displays 245 subfields out of order
18:08:27 <jenkins_koha> * oleonard: Bug 6291 - Cart printing truncated in Firefox
18:08:27 <jenkins_koha> * paul.poulain: Test suite: ignoring backups from vi (files ending with a ~)
18:08:27 <jenkins_koha> * maxime.pelletier: fix test xml records
18:08:27 <druthb1> #info D Ruth Bavousett, ByWater Solutions (sorry for the late hit)
18:08:27 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=6291 normal, PATCH-Sent, ---, oleonard, ASSIGNED , Cart printing truncated in Firefox
18:08:28 <jenkins_koha> * paul.poulain: history.txt, adding Stéphane Delaune, as 117, moving others and welcome Albert, you're 163th !
18:08:29 <jenkins_koha> * chrish: Bug 5327: Unit tests for C4/Exteral/BakerTaylor.pm
18:08:29 <jenkins_koha> * Chris Cormack: Bug 5327 : Adding more unit tests
18:08:29 <jenkins_koha> * Chris Cormack: Bug 5327 : Complete coverage for BackgroundJob.pm
18:08:29 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=5327 enhancement, PATCH-Sent, ---, gmcharlt, ASSIGNED , Unit tests required for all C4 modules
18:08:30 <Brooke> awesome, if you do that for us, I don't think we'll complain. thanks a heap for the effort. :)
18:08:30 <jenkins_koha> * Chris Cormack: Bug 5327 : Fixing unit test for SQLHelper.pm
18:08:30 <jenkins_koha> * Chris Cormack: Bug 5327: Fixing the Members.t test
18:08:32 <jenkins_koha> * paul.poulain: 160th developer + 2 events added (NZ tm and 3.6.1 released)
18:08:32 <jenkins_koha> * paul.poulain: t/UploadedFile, updated comment
18:08:35 <jenkins_koha> * chris.nighswonger: Release Notes for 3.06.02.000 07 Dec 2011 16:41:07 Z
18:08:35 <jenkins_koha> Starting build 558 for job Koha_master (previous build: STILL UNSTABLE -- last SUCCESS #491 1 mo. 19 j ago)
18:08:44 <sekjal> thanks, jenkins_koha.  quite timely
18:08:45 <slef> jenkins_koha: mute
18:08:45 <jenkins_koha> slef did you mean me? Unknown command 'mute'
18:08:46 <jenkins_koha> Use '!jenkins help' to get help!
18:08:55 <cait> heh
18:09:01 <slef> jenkins_koha: shut up
18:09:01 <jenkins_koha> slef did you mean me? Unknown command 'shut'
18:09:01 <Brooke> #topic Roadmap to 3.6
18:09:01 <jenkins_koha> Use '!jenkins help' to get help!
18:09:14 <chris_n> it appears jenkins wanted to say a few things 3.6 related :)
18:09:15 <paul_p> #info Paul Poulain, BibLibre, RM for 3.8
18:09:24 <paul_p> sorry to be a little bit late !
18:09:31 <Brooke> no problem
18:09:36 <chris_n> 3.6 is on target
18:09:41 * Brooke was deathly afraid of getting caught in a motorcade.
18:09:52 <chris_n> 3.6.2 will release on 22 Dec
18:10:01 <paul_p> chris_n, pushed 1 hour ago 2 more patches that should please jenkins
18:10:16 <paul_p> build 558 should confirm that.
18:10:17 <chris_n> I have a script which is doing pretty much automated release notes each time I push to 3.6.x
18:10:26 <wizzyrea> ^^ awesome
18:10:35 <Brooke> he's cunning
18:10:36 <chris_n> so that should keep all of you folks in the know about what's to be in the next release
18:10:44 <cait> nice
18:10:48 <wizzyrea> chris_n++
18:10:51 <mtj2> yep, chris' script is just awesome
18:10:52 <jcamins> chris_n++
18:10:57 <chris_n> paul_p: looks like we're still unstable :(
18:11:01 <dpavlin> chris_n++
18:11:15 <oleonard> #info Owen Leonard, Athens County Public Libraries
18:11:50 <paul_p> chris_n, I know, but there should be only 4 problems now. And only 2 in fact, as that's problems declared twice
18:11:52 <chris_n> and that's it for 3.6
18:12:01 <Brooke> #topic Roadmap for 3.8
18:12:03 <Brooke> take it away Paul
18:12:16 <paul_p> chris_n, could you explain again your strategy to decide what should be in 3.6 and what will stay for 3.8
18:12:21 <paul_p> (before going to 3.8)
18:12:38 <paul_p> I think it's clear for me, but maybe not for everybody
18:13:01 <chris_n> new features go in 3.8
18:13:17 <chris_n> all else goes in 3.6
18:13:38 <chris_n> a feature is something currently non-existent in 3.6
18:14:01 <sekjal> chris_n: would it be fair to say that anything that changes a workflow would be a considered a feature?
18:14:07 <chris_n> the only real exception is things which are clearly too big to safely move back
18:14:22 <paul_p> for everybody = it means that an improvement to an existing feature, even if it's ENH, will be applied to 3.6
18:14:29 <chris_n> sekjal: I would define that more as "significantly" changes workflow
18:14:41 <chris_n> I think very minor changes are probably acceptable
18:14:54 <paul_p> and I agree with that
18:14:59 <chris_n> but some of this is open to discussion
18:15:09 <sekjal> but, say, the changes to handling Lost items as laid out in bug 5533 would NOT be backported
18:15:09 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=5533 critical, PATCH-Sent, ---, srdjan, ASSIGNED , marking item lost diff in two places
18:15:12 <chris_n> I think fine-days is the issue here
18:15:32 <chris_n> its critical as marked
18:15:39 <chris_n> not enh
18:15:42 <paul_p> chris_n, (one of ) the issue is that it's a bug, not an ENH
18:15:58 <thd> chris_n: Does that mean that complete code rewrites which do not introduce new features will be allowed in 3.6?
18:15:59 <paul_p> even if fixing the problem means changing (a little bit) the workflow
18:16:29 <chris_n> thd: for example?
18:16:46 <cait> paul_p: the problem I see is the change for the debar handling
18:16:49 <cait> with dates and notes
18:17:06 <chris_n> thd: in reality they would not
18:17:07 <cait> a short warning to libraries updating might be good at least
18:17:10 <cait> in the release notes
18:17:19 <thd> chris_n: sorry, my question was meant with more humour than seriousness :)
18:17:26 <paul_p> cait, right. and that's what we were/are supposed to do.
18:17:26 <chris_n> :)
18:17:36 <paul_p> chris_n, was it in 3.6.1 ? (I think no)
18:17:41 <Brooke> thd Koha is srs buisnass ;)
18:17:56 <chris_n> paul_p: it?
18:18:05 <magnuse> #info Magnus Enger, Libriotech, Norway
18:18:06 <paul_p> chris_n, finedays
18:18:18 <chris_n> it does not apply cleanly atm
18:18:32 <mib_9y99lh> Question - I have the system set up to send emails to patrons about everything, yet it never sends emails, the status is always "pending".  Could there possibly be something I haven't clicked?  I feel like I've checked every box known to man.
18:18:40 <sekjal> a good plumbing-level-only change could be done without changing any outward appearance
18:18:50 <paul_p> chris_n, on 3.6 ? really ?
18:18:54 <sekjal> the followup for bug 5211 is a small example thereof
18:18:54 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=5211 major, PATCH-Sent, ---, srdjan, ASSIGNED , marking lost (long overdue) not charging fines
18:18:59 <chris_n> paul_p: I'll look
18:19:01 <oleonard> Sorry mib_9y99lh, we are having a meeting at the moment
18:19:06 <jcamins> mib_9y99lh: there is a meeting going on right now, so you may have more luck in an hour.
18:19:13 <jwagner> mib_9y99lh, there is a meeting going on -- check to make sure the process_message_queue.pl cron job is running
18:19:37 <chris_n> paul_p: whats the bug number?
18:19:41 <mib_9y99lh> I didn't realize this was not the place to ask questions.  My bad.
18:19:50 <Brooke> it is just not right now ;)
18:19:50 <paul_p> chris_n, 632_
18:19:51 <jcamins> mib_9y99lh: no, it is. You just came at a bad time.
18:19:52 <jwagner> It's the place, just not the time
18:19:53 <paul_p> chris_n, 6328
18:19:59 <cait> it is the place, but once a month there is a meeting
18:20:23 <Brooke> if ye send it to the listserv, someone will pick it up most likely
18:20:43 <cait> ok
18:20:44 <chris_n> paul_p: its not in 3.6.x atm, and would not apply cleanly
18:20:45 <cait> fines in days?
18:20:46 <wahanui> i guess fines in days is debatable imho
18:20:59 <chris_n> seems so wahanui
18:21:02 <Brooke> rather than discuss every little bug
18:21:16 <Brooke> how bout we say that if there's a question, Paul and Chris will have a cage match
18:21:36 <paul_p> Brooke, you're right. but chris_n, please let me know if 6328 does not apply, because it's a BLO for us !
18:21:44 <chris_n> is there a large amount of concern about introducing fine-days fixes into 3.6?
18:21:56 <chris_n> paul_p: it does not
18:22:07 <chris_n> or would not for me this morning
18:22:18 <chris_n> I have to had time to update the bug
18:22:21 <paul_p> chris_n, for all french libraries, and most Spanish / italian libraries it is !
18:22:55 <paul_p> as, 99% of french libraries use fines in days
18:23:14 <paul_p> well... 60%. 39% doing no fines at all, and 1% fines in €
18:23:17 <cait> perhaps we could get a second sign-off? for 3.6 and a documentation?
18:23:23 <chris_n> if there is a fair amount of concern about introducing fine-days fixes into 3.6.x, please let me know
18:23:40 <paul_p> tajoli, hello ! could you confirm to chris_n that fines in days is something important for you too !
18:23:49 <paul_p> (we're just discussing of this)
18:23:53 <tajoli> yes, I confirm
18:24:08 <slef> I think it probably should be fixed in 3.6.x if not too disruptive
18:24:11 <tajoli> in Italy ALL library in practies use fine in days
18:24:21 <chris_n> sekjal: is this related to your earlier question of workflow?
18:24:28 <jcamins> tajoli: don't forget to introduce yourself with #info
18:24:33 <tajoli> No one use money
18:24:42 <sekjal> chris_n:  yes.  this doesn't just change how fine in days works
18:24:47 <sekjal> it changes how debarred works in general
18:25:00 <tajoli> #info Zeno Tajoli, CILEA (Italy)
18:25:21 <jransom> we use finesin nz
18:25:30 <sekjal> I think it's a great improvement, but I can see a library getting upset because something like this changes on them in the middle of a stable release
18:25:55 <paul_p> sekjal, if it's clearly announced in the release notes, I think it's not a so big change.
18:26:08 <slef> jransom: by charging them money or by banning a borrower for N days?
18:26:13 <chris_n> I'd like to hear from others on this
18:26:22 <jransom> charging money
18:26:29 <chris_n> before making a decision
18:26:30 <paul_p> fair. Do we drop a mail on koha ML ?
18:26:42 <Brooke> yes
18:26:48 <thd> Fixing a bug in a completely broken feature which is a use blocker might need some way of getting into stable.
18:26:48 <Brooke> this is way too granular for the meeting
18:26:56 <Brooke> so
18:27:02 <paul_p> chris_n, you do, or I do ? (the mail)
18:27:02 <cait> thd: the problem is, it never worked since 3.2
18:27:03 <Brooke> paul roadmap to 3.8 svp
18:27:06 <jcamins> moving_on++
18:27:13 <cait> and it changes the API and the interface
18:27:13 <chris_n> paul_p: go ahead
18:27:18 <paul_p> OK, will do.
18:27:19 <cait> that's why there is some concern
18:27:36 <paul_p> OK, 3.8 now
18:28:03 <chris_n> #info bug 6328 is on hold for 3.6.x pending list responses
18:28:03 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=6328 major, PATCH-Sent, ---, paul.poulain, ASSIGNED , Fine in days does not work
18:28:10 <slef> paul_p: can you include an outline of the API change in the mail please?
18:28:11 <thd> The feature even if long broken is not new and is certainly necessary.
18:28:24 <paul_p> 1st a question: do ppl think a monthly mail from me is a good thing ?
18:28:33 <Brooke> yes
18:28:34 <wizzyrea> yep :
18:28:35 <chris_n> yes
18:28:35 <tajoli> For me yes
18:28:35 <wizzyrea> :)
18:28:38 <thd> How do libraries cope without the feature?
18:28:42 <Irma> me too yes
18:28:43 <drojf> yes
18:28:46 <wizzyrea> thd: take it to the list
18:28:47 <jcamins> +1
18:28:51 <cait> +1 for monthly mails
18:28:52 <slef> 0
18:28:53 <paul_p> OK, so I'll continue this way.
18:28:54 <wizzyrea> please
18:28:57 <magnuse> paul_p: yes
18:28:58 <marijana> +1
18:29:01 <davidnind> yes
18:29:08 <dpavlin> yes
18:29:17 <thd> +1 for more mail
18:29:21 <paul_p> if you think there's something I should speak of in everymail, don't hesitate to tell me
18:29:38 <jenkins_koha> Project Koha_3.4.x build #65: STILL UNSTABLE in 1 h 27 mn: http://jenkins.koha-community.org/job/Koha_3.4.x/65/
18:29:38 <jenkins_koha> chris.nighswonger: Release Notes for 3.04.07.000 07 Dec 2011 16:48:02 Z
18:29:39 <paul_p> very fresh news: there are a lot of things made on the performance side.
18:29:49 <paul_p> * i've pushed some patches
18:29:56 <wizzyrea> argle.
18:29:57 <jenkins_koha> Starting build 66 for job Koha_3.4.x (previous build: STILL UNSTABLE -- last SUCCESS #50 2 mo. 0 j ago)
18:30:08 <paul_p> * the "de-nesting C4 package" should also be tested
18:30:24 <paul_p> * BibLibre has a patch that should hit bugzilla soon that improve by 1 second every search !
18:30:27 <magnuse> improving_performance++
18:30:38 <wizzyrea> improving_performance++
18:30:44 <paul_p> * Ian submitted a patch to play with yaml file for config. I'll test it tomorrow I think
18:30:58 <paul_p> * i've started a page with benchmarking on the wiki
18:31:16 <paul_p> that's probably the main thing i'll focus on in december !
18:31:24 <Brooke> #info paul's pushed a bunch of patches
18:31:25 <paul_p> I plan to focus on one thing each month.
18:31:33 <tcohen> is anyone working on Bug 6802
18:31:33 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=6802 critical, P5 - low, ---, gmcharlt, NEW , with IndependantBranches  on can still edit items
18:31:34 <tcohen> ¡
18:31:36 <tcohen> ?
18:31:36 <paul_p> this month, speed
18:32:05 <sekjal> tcohen:  several ByWater partners have expressed concern over it, but we don't have a finalized plan of attack het
18:32:11 <sekjal> s/het/yet/
18:32:32 <paul_p> I almost forget: bywater & catalyst are working on Plack/mod_perl
18:32:45 <bag> yes
18:32:47 <paul_p> sekjal, i'll drop you a mail tomorrow about that, I want to participate ;-)
18:32:57 <sekjal> paul_p:  most excellent
18:33:01 <bag> hey paul_p please cc me
18:33:18 <paul_p> bag ? (who are you ?) -sorry, I missed the beginning)
18:33:19 <tcohen> let us know, we're concerned about that as it is holding a university fromr migrating
18:33:27 <bag> bag = brendan :)
18:33:37 <bag> bag = brendan arthur gallagher
18:33:48 <mtj2> bg?
18:33:49 <wahanui> I LOVE BASEBALL AND BREAKFAST BURRITOS
18:33:57 <bag> yup that bg :)
18:34:04 <paul_p> multiple_nicks-- ;-)
18:34:07 <slef> paul_p: do you mean to #info not *?
18:34:08 <slef> what bug is yaml-for-config?
18:34:08 <slef> @query yaml config
18:34:08 <slef> huginn`: hello?
18:34:09 <mtj2> zAngG!
18:34:12 <huginn`> slef: 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7170 normal, P3, ---, paul.poulain, NEW , Remove use of XML::Simple
18:34:13 <huginn`> slef: 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=6915 minor, PATCH-Sent, ---, gbarniskis, ASSIGNED , koha_perl_deps.pl truncates long module names at 26 chars
18:34:14 <huginn`> slef: 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=7167 enhancement, PATCH-Sent, ---, paul.poulain, ASSIGNED , updatedatabase improvements
18:34:14 <paul_p> (ok, will cc you, of course)
18:34:15 <huginn`> slef: 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=6488 normal, PATCH-Sent, ---, srdjan, ASSIGNED , opachiddenitems not working in master
18:34:16 <huginn`> slef: 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=6193 enhancement, PATCH-Sent, ---, tomascohen, ASSIGNED , Use memcached cache koha-conf.xml configuration variables
18:34:17 <huginn`> slef: I've exhausted my database of quotes
18:34:22 <wizzyrea> I have a concern about patches that are skipping the QA step - I've seen a couple now, bug 4051, for example doesn't seem to have had a going over by one of the designated qa folks.
18:34:22 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=4051 enhancement, PATCH-Sent, ---, adrien.saurat, ASSIGNED , add columns to overdues export
18:34:53 <paul_p> wizzyrea, they haven't skipped the QA test, it's just that I made the QA.
18:34:54 <slef> oof sorry folks I just fell offline
18:34:57 <paul_p> (and pushed)
18:35:10 <wizzyrea> but, that's not the agreed situation?
18:35:27 <paul_p> wizzyrea, yes, that is.
18:35:29 <sekjal> wizzyrea:  the current set of QA rules we're operating under allow the RM to jump straight from a "Signed Off"  to a "Pushed"
18:35:46 <wizzyrea> I see.
18:35:47 <sekjal> provided that the author/signer are not from the same company
18:35:50 <sekjal> as the RM
18:35:50 <paul_p> I just don't do that for a patch made by BibLibre and signed-off by BibLibre too
18:36:01 <paul_p> and I try to do that on small patches.
18:36:06 <cait> if that's the agreed set of rules
18:36:09 <cait> should go on the wiki
18:36:15 <wizzyrea> hmm, 4051 doesn't follow that paradigm.
18:36:20 <cait> I am a bit more worried about untested follow ups
18:37:02 <paul_p> wizzyrea, I promize chris_c has not been hired by BibLibre yet ;-)
18:37:07 <sekjal> wizzyrea:  signoff is by rangi
18:37:08 <dpavlin> wizzyrea: I tend to belive RM with final decisions... What is your concern?
18:37:26 <paul_p> cait, do you have an example ?
18:37:45 <cait> the updatedatebase to the 'unknown' problem for item_DUE
18:37:56 <cait> sorry, I have a problem with numbers
18:37:58 <cait> but can find it
18:38:01 <paul_p> I have added a few follow-ups, but that was only comments or very minor things like that. Except for the item_DUE, that I tested before pushing.
18:38:32 <wizzyrea> ok, I concede that you got a signoff external to biblibre, but the patch was originally biblibre, and didn't go through a non biblibre QA. I'm not trying to generate work, I'm just trying to understand the rules.
18:38:33 <paul_p> cait, would you have prefered a failed QA because the updatedatabase is missing ?
18:38:42 <cait> yes
18:38:47 <cait> let me explain
18:39:11 <paul_p> wizzyrea, 4 steps (provide patch / sign-off patch / QA / push), there must be at least 2 companies involved.
18:39:12 <cait> and sorry for picking that - it was the fist I was thinking of
18:39:44 <paul_p> and, for "large" patch, I won't QA myself, even if I could with our rules
18:39:51 <cait> I was very surprised about the version numbering for this, so it's a good example perhaps anyway
18:40:07 <cait> and it would not have hurt to push the first patch - and the updatedatabase later on
18:40:09 <slef> I feel that RM should be reluctant to QA. If RM=QA then we've one less set of eyeballs. But sometimes it's necessary.
18:40:29 <cait> sorry, not trying to be annoying
18:40:30 <wizzyrea> I agree with slef.
18:40:33 <paul_p> cait, that's a topic i've added (database version)
18:40:46 <paul_p> maybe I changed something, without knowing...
18:41:01 <sekjal> #link http://www.mail-archive.com/koha-devel@lists.koha-community.org/msg02253.html
18:41:20 <tajoli> Personaly I think that same time RM=QA is OK. Fore example SQL file of no-english languages
18:41:41 <paul_p> in the last days, I made some QA, but it was only for small/obvious patches, except the item_DUE one.
18:42:36 * slef notes his internet connection quality has gone through the floor :(
18:43:06 <wizzyrea> well I guess I'll be happy with it if it's the approved process.
18:43:06 <sekjal> in the link I just posted, I laid out 6 rules for QA
18:43:15 <cait> like wizzyrea said
18:43:21 <cait> or what she said
18:43:22 <sekjal> the only response on that thread was from paul_p
18:44:09 <wizzyrea> sekjal: your rules are sane.
18:44:20 * magnuse gotta catch a plane
18:44:46 <sekjal> thanks, wizzyrea.  I'd hoped so.  I think what remains is for the community as a whole to ratify or reject them
18:44:47 <slef> sekjal: I remember replying to the signed-off patches point. :-/
18:45:01 <Brooke> put it on the agenda
18:45:05 <wizzyrea> aha
18:45:10 <Brooke> that's how things get ratified or rejected :P
18:45:24 <sekjal> slef:  there were several concurrent threads on similar subjects; I may have misplaced your response.  looking...
18:46:11 <slef> sekjal: I may have mistakenly discarded the thread you linked as a duplicate. Too many people still cross-post to koha and koha-devel and sometimes it confuses me.
18:46:28 <rangi> morning
18:46:32 <Brooke> morena
18:46:37 <paul_p> 'morning rangi
18:46:48 <Brooke> we're getting really granular again
18:46:49 <Brooke> so
18:46:55 <paul_p> Brooke++
18:46:56 <Brooke> what do we want to do about qa?
18:47:11 <tajoli> Chiris, on your mail about 3.4.7 you insert the line RELEASE NOTES FOR KOHA 3.6.2
18:47:11 <Brooke> or were we just seeking a clarification?
18:47:27 <paul_p> i've another concern about QA/jenkins
18:47:43 <paul_p> i've added it on the agenda: when jenkins complains, what should be do ?
18:47:55 <wizzyrea> I think what he's doing now is just peachy
18:48:08 <wizzyrea> (good)
18:48:09 <rangi> ppl should fix the stuff they broke
18:48:09 <slef> (a slightly more general aside: can any msg me how to get a complete mbox-like copy of sekjal's email so I can reply to it?)
18:48:12 <Brooke> k moving on to what paul just mentioned
18:48:21 <Brooke> #topic Pushing a Patch with a Jenkins complain
18:48:22 <joannR> brooke: what will do with these parked 'granular' issues that do need addressing
18:48:31 * rangi spent a few hours yesterday doing that for others
18:48:39 <Brooke> hopefully they'll go out to the list
18:48:46 <Brooke> get some sort of resolution
18:48:51 <rangi> bug 5327
18:48:51 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=5327 enhancement, PATCH-Sent, ---, gmcharlt, ASSIGNED , Unit tests required for all C4 modules
18:48:54 <Brooke> and come up again in a more condensed version
18:49:02 <rangi> and bug 5604
18:49:02 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=5604 normal, PATCH-Sent, ---, nengard, ASSIGNED , additional icons for the Seshat set
18:49:07 <Brooke> or be ironed out on IRC while it's not the meeting
18:49:08 <paul_p> rangi++
18:49:11 <rangi> patches on those
18:49:23 <Brooke> we could address them here every month, but that is how you get 8 hour meetings.
18:49:25 <slef> paul_p: I'd pick option 1.5 ;-) maybe slower than immediate revert if a fix is promised, but revert breakages faster than a week if possible, else it may block some testers
18:49:27 <rangi> will stop jenkins complaining
18:49:28 <paul_p> i've pushed another fix to tests (boolean.t was wrong)
18:49:47 <cait> Brooke: I think we should talk about that here
18:49:50 <cait> really
18:50:25 <jransom> QA practice  is a critical issue
18:50:34 <tcohen> are we using any mock libs for unit tests?
18:50:37 <cait> I agree that we can't have unit tests and keep breaking them for weeks
18:50:44 <jransom> (but dont want an 8 hour meeting either :)
18:50:45 <cait> things that break unit tests should not go in
18:50:46 <cait> fail qa
18:50:47 <paul_p> cait++
18:51:22 <wizzyrea> right so that means that as developers we probably need to be more fastidious about running the unit tests on our work
18:51:23 <cait> it's easy to run the tests - we should add it to the development and qa workflows
18:51:24 <slef> well, yes, that's another aspect: why would such a thing be pushed?
18:51:31 <tcohen> cait++
18:51:56 <cait> and if it breaks - either the tests are wrong or the feature - but both should be fixed.
18:51:57 <drojf> cait++
18:52:04 <paul_p> cait, it's easy to run the tests, but there are so many, you don't always know which one to run
18:52:06 <slef> the developer failed to test, the signed-offer failed, QAM didn't flag it and RM didn't notice?
18:52:13 <cait> you can run them all
18:52:14 <cait> it's not that long
18:52:17 <cait> prove
18:52:27 <cait> one line in a window, do something else in another ;)
18:52:30 <paul_p> cait, jenkins need more than 1 hours to run all the tests !
18:52:50 <paul_p> rangi told me he ran 00.* before pushing anything.
18:52:58 <wizzyrea> #action someone please add documentation to the developer/git pages on the wiki on "how to run tests"
18:53:17 <Brooke> #help Add Documentation about Testing to the wiki
18:53:35 <tcohen> is there a guidelines section for writing testsunit ?
18:53:35 <cait> not usre, I thought they were running faster last time I did
18:53:38 <rangi> if you change a module, u should at least run its test
18:53:40 <paul_p> I think it's OK to have jenkins complaining, if we have a clear workflow like "if jenkins complains, if a patch is not provided in the next 7days, it will be reverted"
18:53:53 <cait> so perhaps it's a bit harder, but still not too hard
18:54:04 <wizzyrea> well I think we should head those off
18:54:09 <rangi> or change a template, run those tests
18:54:10 <wahanui> rangi: that doesn't look right
18:54:12 <wizzyrea> developer should run the test on their own work
18:54:22 <cait> forget that
18:54:23 <wahanui> cait: I forgot that
18:54:24 <wizzyrea> signoff should run the tests
18:54:27 <cait> that is <reply>
18:54:40 <rangi> u dont have to run all, but at least the relevant ones
18:54:40 * jcamins didn't find the tests took that long when he tried running them. I think Jenkins is on a VPS that doesn't have a lot of power because rangi donated it.
18:54:51 <wizzyrea> (and say they did, if they did, then qa may not need to!)
18:54:53 <cait> rangi++
18:54:56 <rangi> its on a biblibre one now
18:54:57 <paul_p> wizzyrea/rangi= but you have to know which one are relevant !
18:55:13 <wizzyrea> i am ok having a window on my test system running all of the tests.
18:55:27 <wizzyrea> as step 1 in this process.
18:55:30 <rangi> yes but if you change members.pm run at least members.t
18:55:41 <paul_p> agreed
18:55:46 <wizzyrea> and if you don't know, run em all!
18:55:52 <sekjal> any change to a C4 module requires that module to be tested (at least)
18:55:53 <rangi> if ppl want
18:55:53 <wizzyrea> you can always reference against jenkins
18:56:10 <paul_p> that could/should be added to QA workflow, isn't it ?
18:56:15 <paul_p> (in the QA comments)
18:56:21 <rangi> I can run a test writing tutorial on irc
18:56:34 <wizzyrea> I think it ought to be at all stages, developers are responsible too
18:56:45 <mtj2> and if you did run *some* of the tests, for your patch - then state that info in the bugzilla update, etc...
18:56:46 <paul_p> rangi, test writing & test running ?
18:56:52 <rangi> so ppl can add tests when the add functions too
18:56:56 <rangi> yep
18:57:01 <paul_p> great !
18:57:06 <rangi> I can show how to set git hooks
18:57:07 <wizzyrea> 1. if a dev runs the tests -> qa won't find anything wrong
18:57:14 <rangi> so git does it for u
18:57:33 <jcamins> rangi: oh, well, I still didn't think it took me an hour to run the tests.
18:57:36 <jcamins> rangi++
18:57:51 * oleonard wants to know more about git hooks
18:58:02 <dpavlin> should we run tests under some kind of harness and collect results like CPAN does? This might prove very useful for tracking endge cases?
18:58:09 <rangi> takes about 20 mins on my desktop
18:58:23 <Brooke> #idea harness test results
18:58:28 <paul_p> rangi, why does it take 1hour for jenkins ?
18:58:31 <Brooke> #idea teach people about the testing process
18:58:41 <cait> rangi++
18:58:42 <paul_p> (and just 20mn for you?)
18:58:43 <cait> love that idea
18:58:44 <rangi> it does a full makefile.pl
18:58:47 <Brooke> #idea update documentation to reflect what different developers do
18:58:53 <Brooke> making_koha_better++
18:59:01 <rangi> and runs coverage tests too
18:59:19 <rangi> plus its java :)
18:59:31 <wizzyrea> keke
18:59:35 <rangi> and my desktop has a lot more ram
18:59:38 <paul_p> what's the diff between t and xt ?
19:00:04 <rangi> xt are not functional
19:00:08 <jransom> yup
19:00:09 <paul_p> (maybe not a question for the meeting...)
19:00:17 <jransom> oops
19:00:21 <rangi> the test things like are things transltable
19:00:24 * chris_n agrees that it is the dev's job to run tests and fix them
19:00:25 <rangi> etc
19:00:41 <jransom> im off folks - meetings to get to
19:00:42 <chris_n> probably if a patch breaks a test it should be rejected
19:00:42 <rangi> ok my bus stop bb soon
19:01:24 <wizzyrea> chris_n++ i agree - and qa should run them (if the signoff doesn't say that they did)
19:01:32 <paul_p> Brooke, next topic ?
19:01:44 <Brooke> not sure if we're exhausted on this
19:01:53 <Brooke> folks, what's your pleasure? We all talked out?
19:02:00 <wizzyrea> which actually brings up another question for me - how far does the responsibility of the signoff person go?
19:02:02 <mtj2> if we can get better wiki-doc for devs running tests on their patches, we will all win - big time :)
19:02:19 <wizzyrea> make sure the functionality works? check the code for formatting errors?
19:02:24 <paul_p> mtate, right.
19:02:25 <wizzyrea> run the tests?
19:02:26 <chris_n> mtj2: prove t && prove xt
19:02:36 <paul_p> wizzyrea, make sure the feature works
19:02:41 <chris_n> then just watch the results
19:02:48 <paul_p> QA being "how the code is written"
19:02:49 <slef> wizzyrea: bare minimum, make sure the functionality works IMO. Ideally check formatting and run tests (and say that you have).
19:03:06 <cait> wizzyrea: I think important is to state what you have done in the patch or bug
19:03:13 <thd> wizzyrea: Depends on the standard which QA has the time to test.
19:03:14 <chris_n> cait++
19:03:15 <wizzyrea> ok cool, I always felt guilty when one of my signoffs dies in QA
19:03:20 <cait> so someone else will know what was tested and can do more testing based on that
19:03:26 <cait> if he/she thinks something was missed
19:03:50 <wizzyrea> "was my testing bad?"
19:03:51 <thd> wizzyrea: What slef said a minimum and document the level of testing.
19:04:03 <cait> we all miss things, we can only try to document what we do
19:04:04 <cait> I think
19:04:11 <wizzyrea> thanks, that clears it up for me
19:04:30 <paul_p> wizzyrea, when I QA, I sometimes don't look at the feature. I look at the code itself.
19:04:42 <wizzyrea> ^^ that is EXTREMELY helpful to know
19:05:08 <wizzyrea> so signoff = working as intended from the UI
19:05:17 <slef> I've failed at this myself. I will improve.
19:05:18 <chris_n> final QA is normally done during "alpha" and "beta" releases
19:05:23 <paul_p> (well 60% of the time, I also look at the feature. But with the *great* tests plan made by ppl like cait, it's often very easy !)
19:05:23 <thd> paul_p: How can you be certain that the code did not mislead you into believing that the feature works?
19:05:24 <chris_n> which we don't do
19:05:55 <wizzyrea> QA = look at the feature (possibly) and look at the code
19:05:56 <paul_p> thd, i'm not, I trust the author/signoff-er.
19:06:25 <slef> trust no-one
19:06:38 <slef> it's not paranoia because they're all out to get you
19:06:42 <paul_p> and, when the signoff has been made by cait or wizzyrea or oleonard, i'm more comfortable than when it has been signed-off by someone I never saw before
19:06:58 <thd> paul_p: OK. I usually find the other way round that testing the feature misleads people into believing that the code works.
19:06:59 <rangi> back
19:07:30 <thd> s/works/works as intended/
19:07:41 <paul_p> thd, right, and/but it really depends on how large the patch is and what kind of thing it impacts
19:07:48 <cait> paul_p: I miss things too, all the time
19:07:53 * wizzyrea too
19:08:02 <Brooke> so here's a thought
19:08:03 <Brooke> how about
19:08:10 <Brooke> we figure out when a logical downtime is
19:08:18 <Brooke> and run a training session for bugtesting
19:08:19 <chris_n> yes, but if QA includes running the test suite, you won't miss those failures
19:08:24 <thd> paul_p: I concede that for very small patches looking at the code is about the only useful thing to do.
19:08:26 <Brooke> or at least a moot about how folks test for qa
19:08:29 <chris_n> unless your screen breaks
19:08:30 <wizzyrea> what chris_n says
19:08:37 <Brooke> hackfest is logical, but lots of folks don't make conference
19:08:49 <chris_n> running the suite is super simple too
19:09:21 <wizzyrea> I think that we should strive to keep jenkins happy
19:09:22 <paul_p> Brooke, the idea of training session for bugtesting is great.
19:09:35 <thd> Brooke++
19:09:40 <wizzyrea> if jenkins is unhappy, someone has not done their job.
19:09:41 <paul_p> francharb was really pleased with what he learned at KohaCon11 !
19:09:59 <wizzyrea> and we're not going to point and blame - we're going to just fix it already.
19:10:00 <francharb> ++
19:10:03 <francharb> thats true!
19:10:06 <Brooke> #idea a bugtesting training session at some point in a release cycle to bring new folks in and put old folks on the same page
19:10:23 <indradg> Brooke++
19:10:42 <francharb> one day i will write a "git-bz for the noob" post on biblibre blog! ;)
19:10:45 <paul_p> BibLibre will also organize a week of hackfestin march 2012
19:10:50 <wizzyrea> git bz is amazing
19:10:55 <paul_p> (like last year)
19:11:06 <cait> that was the idea of gbsd
19:11:08 <paul_p> it should be week 12 of 2012
19:11:18 <cait> to make more people interested and show them how to do things
19:11:19 <cait> in a group
19:11:22 <wizzyrea> oh, we should take a gbsd and squash the bugs out of our qa process :P
19:11:24 <chris_n> wizzyrea: we can keep jenkins happy if either QA or the RM will run the suite before every push
19:11:27 <paul_p> (should be confirmed and announced loudly next week)
19:11:30 <cait> we could add that to the next gbsd perhaps?
19:11:30 <wizzyrea> *nod*
19:11:35 <cait> some training sessions?
19:11:37 <chris_n> and we don't need a training session to do that
19:11:50 <cait> explicitly in the announcement, perhaps with times
19:11:51 * paul_p agrees for some training on next gbsd
19:12:01 <Brooke> #idea use next gbsd for bugtesting training
19:12:34 <chris_n> paul_p: what is wrong with running the test suite before you push and rejecting patches which cause failures?
19:12:51 <paul_p> chris_n, how long it takes
19:13:01 <slef> #idea someone add the set-bugzilla-metadata-like-status to git bz before I get time
19:13:04 <chris_n> so time trumps quality
19:13:06 <chris_n> ?
19:13:21 * dpavlin confused. prove t/ && prove xt/ takes 27+4 seconds for me. Am I missing something?
19:13:27 <paul_p> not only, jenkins is here to do that. What I must improve is my reaction when jenkins complains
19:13:33 <chris_n> no
19:13:42 <chris_n> I think what dpavlin said is true here
19:13:47 <cait> paul_p: perhaps try to run them on your local machine again?
19:13:51 <rangi> dpavlin: there is the t/db_dependent suite too
19:14:02 <cait> or part of it
19:14:04 <chris_n> even that is worth the wait
19:14:05 <cait> as rangi suggested
19:14:18 <jcamins> dpavlin: prove t ; prove xt ; prove t/db_dependent
19:14:43 <paul_p> db_dependant also requires to have a specific database (isn't it rangi ?)
19:14:46 <rangi> the important ones for templates images pod
19:14:53 <rangi> are in xt/author/
19:15:16 <dpavlin> Thanks, keep hints comming, I will turn them into wiki page after meeting :-)
19:15:17 <rangi> any change you make to templates those are good to run, and are fast
19:15:24 <wizzyrea> dpavlin++
19:15:29 <paul_p> dpavlin++
19:15:35 <chris_n> dpavlin++
19:15:38 <cait> dpavlin++ for that and other useful documentation work!
19:15:39 <rangi> paul_p: a db with all the sample data loaded in, should work
19:15:42 <jcamins> dpavlin++
19:15:51 <wizzyrea> ooo
19:16:10 <paul_p> the sample datas that are in installer/data/mysql/en/* ?
19:16:17 <paul_p> rangi, the sample datas that are in installer/data/mysql/en/* ?
19:16:21 <rangi> yup
19:16:28 <paul_p> ok, will check & try
19:16:29 <rangi> i havent set up a new one in a while
19:16:33 <rangi> but thats how i did it
19:17:01 <Brooke> okie dokie
19:17:10 <Brooke> now I think we can move to DB Version Numbering
19:17:11 <Brooke> yes?
19:17:13 <wizzyrea> great, thanks for talking that out peeps I feel a lot better.
19:17:23 <mtj2> rangi: cool, is that the same db that jenkins is running every test too?
19:17:33 <paul_p> Brooke, I think so.
19:17:39 <Brooke> #topic DB Version Numbering Bug 6530
19:17:39 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=6530 major, PATCH-Sent, ---, katrin.fischer, REOPENED , item due notice label saying 'unknown'
19:18:15 <paul_p> Here is my question: the next stable release will be 3.6.2, it means patches with an updatedatabase I push those days should be numbered 3.06.02.xxx, isn't it ?
19:18:29 <cait> I think we used to do it differently
19:18:37 <wizzyrea> well
19:18:40 <cait> but this can be discussed
19:18:51 <cait> it's a bit confusing that my master installation believes to be a 3.6.2
19:19:01 <paul_p> that's what rangi & chris_n told me, but I don't understand how/what it works
19:19:10 <chris_n> well
19:19:15 <paul_p> cait, but for ppl running stable/3.6.x, it's OK
19:19:22 <chris_n> it only "believes" that because of the way the number is parsed by about.pl
19:19:41 <rangi> i always pushed 3.3 and 3.5 to master
19:19:53 <rangi> chris_n pushed 3.2 and 3.4 ones
19:19:54 <wizzyrea> odd numbers = dev version
19:19:56 <chris_n> however, we have been using odd numbers for development cycles and evens for stable
19:20:10 <cait> i liked it
19:20:13 * wizzyrea too
19:20:16 <paul_p> so, does it mean a DB rev that is in both will have 2 numbers ?
19:20:18 <cait> and easy to find out what someone is really running
19:20:23 <paul_p> (2 different numbers I mean)
19:20:26 <cait> paul_p: yes, that's how it was
19:20:50 <paul_p> so, when someone upgraded from a 3.2.x to 3.4.0, he got some update made twice ?
19:20:51 <rangi> usually very few go on the stable one
19:20:56 <rangi> no
19:21:07 <paul_p> so there's something i'm still missing !
19:21:20 <rangi> he wouldnt go 3.2.x to 3.3.x to 3.4.x
19:21:34 <rangi> so would only get it once
19:21:42 <wizzyrea> 3.2.x -> 3.4.0 directly.
19:22:35 <paul_p> mmm, sorry, I don't have it
19:23:02 <cait> perhaps looking at the updates for the last version will help to clear things up?
19:23:10 * chris_n thinks the bottom line is either way works so it is a matter of preference
19:23:13 <paul_p> cait, maybe
19:23:24 <cait> chris_n: for me part of it is consistency
19:23:29 <chris_n> so long as we don't move backwards :-)
19:23:35 <cait> and being able to ask someone who shows upon irc
19:23:37 <wizzyrea> we all know cait loves consistency
19:23:40 <cait> what he is running
19:23:43 <cait> nothing wrong with that :)
19:23:47 <chris_n> consistency++
19:23:56 <cait> I like change too - as long as it's consistent change :P
19:24:13 * wizzyrea ponders the fact that koha is nothing if not consistent change ;)
19:24:38 <paul_p> cait, if someone run master, he usually know it ! and when master becomes stable, a new "fake" DBrev will be introduced to tell him "3.08.00.001"
19:25:00 <cait> paul_p: I think I have to disagree here - people do weird tihngs :)
19:25:19 <cait> and: someone else installed it for me... I don't know what he did
19:25:21 <jcamins> paul_p: I disagree too.
19:25:34 <jcamins> A lot of people seem to have no idea what they're running.
19:25:55 <Brooke> in the before time, there was no about page.
19:26:22 <mtj2> fiy: i think about.pl could be improved to detect/report a master install better
19:26:34 * Brooke nods.
19:26:39 <rangi> how
19:26:42 <rangi> if not by version number
19:26:51 * paul_p digging into gitweb...
19:26:52 <rangi> how could it possibly know otherwise
19:26:55 <chris_n> @quote add <jcamins> A lot of people seem to have no idea what they're running.
19:26:55 <huginn`> chris_n: The operation succeeded.  Quote #170 added.
19:27:57 <chris_n> well
19:27:58 <mtj2> rangi: the next point release after stable is master?
19:28:06 <cait> you can download snapshots from git too - so no need for it to be a git install
19:28:18 <chris_n> given paul_p's current practice about.pl could look at the dev portion of the version number
19:28:27 <rangi> no its not
19:28:30 <chris_n> given the other way, it could look for an odd minor reve number
19:28:41 <rangi> mtj2: 3.6.1 is 3.6.x branch
19:28:45 <cait> dep portion of the version number?
19:28:47 <cait> dev...
19:29:00 <mtj2> ie: is 3.6.x is stable, then 3.x.x means you are running master?
19:29:00 <chris_n> cait: see comments in kohaversion.pl
19:29:20 <mtj2> oops, s/is/if/
19:29:37 <cait> chris_n: sorry, don't get it, perhaps later
19:29:40 <rangi> right so version numbers
19:29:43 <paul_p> OK, I think i've my example...
19:29:50 <rangi> and no i might be running 3.2.x or 3.4.x
19:29:54 * chris_n thinks the arcane knowledge hidden there has been lost in the mists of koha history
19:29:59 <paul_p> in 3.4 updatedatabase :
19:30:15 <paul_p> 4425 $DBversion = "3.04.05.001";
19:30:22 <paul_p> it's the same as in master
19:30:33 <paul_p> $DBversion = "3.05.00.019";
19:30:40 <rangi> yes
19:30:57 <paul_p> SO, someone running 3.4.5 and upgrading to 3.6.0 will have 3.5.0.019 run
19:30:58 <rangi> but not 3.6.x
19:31:02 <rangi> no
19:31:10 <paul_p> ???
19:31:19 <paul_p> (that's what I've missed I feel)
19:31:24 <rangi> not nessecarily, some are checked
19:31:48 <rangi> generally it works because you dont do updatedatabase on stable branches
19:31:55 <rangi> unless its a big bug
19:31:56 <paul_p> (in this case, it's not -but it won't harm, the UPDATE will just make nothing-)
19:32:08 <rangi> and yup
19:32:39 <rangi> but if we number it 3.6.x we still have 3.4.x branch now, so it just shifts the problem
19:32:43 <paul_p> OK, but I feel it introduces a risk of inconsistency
19:32:49 <paul_p> (and inconsistency is bad ;-) )
19:33:02 <paul_p> rangi, right
19:33:03 <chris_n> so we need to patch kohaversion.pl to explain correctly then
19:33:27 <rangi> so i still like master to run odd numbers so its obvious its dev
19:33:32 <rangi> and stable even
19:33:37 <Brooke> #help patch kohaversion.pl to explain numbering
19:33:39 <paul_p> maybe all this discussion will become useless with the new DB update system : we could have "patch applied" coming from the db update and "kohaversion" coming from kohaversion.pl !
19:33:56 * chris_n tends to lean toward the even/odd system too
19:34:13 <paul_p> rangi, you mean that before releasing, you update all DB numbers in updatedatabase ?
19:34:48 <rangi> no, i think we are talking past each other and that the problem is not solvable by using different numbers
19:34:57 <schuster> question for your jquery folks - on the results page in opac can jquery change [electronic resource] to say [ebook title] so we wouldn't have to break cataloging rules and "redo" all of those MARC records?
19:35:04 <wizzyrea> schuster: meeting time
19:35:08 <rangi> schuster: we are in a meeting
19:35:11 <schuster> oh sorry...
19:35:22 <wizzyrea> :) all good :)
19:35:27 <rangi> paul_p: so whatever number we use because we have 3 branches
19:35:35 <rangi> there will be the chance of double ups
19:35:46 <rangi> so just pick a convention, and stick with it is fine
19:35:47 <cait> schuster: yes
19:36:28 <schuster> got my answer thanks all - I even knew there was a meeting today. sorry
19:36:43 <wizzyrea> don't be
19:37:04 <Brooke> k
19:37:08 <Brooke> we talked out on this?
19:37:13 * Brooke not so secretly hopes so.
19:38:13 <Brooke> #topic KohaCon 2012
19:38:15 * chris_n thinks it is a matter of preference more than a matter of functionality
19:38:18 <chris_n> opps
19:38:24 <Brooke> slef go!
19:38:33 <paul_p> Brooke, I think so, but i'm still not clearly decided... will think of it and maybe drop a mail to koha-devel !
19:38:36 <wizzyrea-lunch> (sorry, gonna eat my arm off)
19:38:41 <chris_n> lol
19:38:43 <slef> #link http://wiki.koha-community.org/wiki/Category:KohaCon12
19:39:02 <slef> We're still negotiating the venue *sigh*
19:39:11 <Brooke> time's a tickin
19:39:21 <paul_p> slef, nego with who ?
19:39:22 <cait> so no dates yet?
19:39:42 <slef> Yeah. I thought we had an agreement, but then what we were mailed diverged in some important ways, so round we go again.
19:40:09 <slef> I'm 98% sure we'll be 5th-11th June 2012.
19:40:17 <cait> cool!
19:40:32 <Brooke> if it's not nailed down by next meeting, then what?
19:40:41 <slef> But I don't want to tell people to buy travel until we're sure.
19:41:06 <slef> Brooke: if it's not nailed down before Christmas, I think we switch to a backup venue.
19:41:13 <Brooke> k
19:41:27 <Brooke> cause it's probably cutting a real fine line with folks' budgeting cycles
19:41:27 <thd> slef: Do you have a backup venue?
19:41:46 <slef> thd: yes
19:42:11 <Brooke> anything else that's new or interesting to report?
19:42:24 * thd thinks tents on the city green would be a fine backup venue.
19:42:28 <slef> those of you who have seen pics/vids, hopefully can see why we think this is first choice
19:42:43 <paul_p> slef, how do you plan to have the conf: 3 days conf + 3 days hackfest ?
19:42:56 <paul_p> with 1 day of between them ?
19:43:07 <slef> #help please put into the wishlist ideas you want
19:43:18 <slef> paul_p: yes, exactly that! :)
19:44:07 <cait> only 3 days hackfest?
19:44:12 <cait> ;)
19:44:17 <slef> I'd also like any ideas for the day off, please; and if anyone might be interested in a road trip from any English cities (I guess many will fly into London?)
19:44:33 <Brooke> road trip++
19:44:50 <Brooke> <--- prolly not going though
19:44:53 <paul_p> slef, fly to london ? why ? Isn't Edinburg a great place ?
19:45:02 <slef> I think ideas we have had are a tour of Edinburgh and a fishing trip. But first we sort out the conf.
19:45:04 * paul_p dreams of a day off in the country...
19:45:16 <jcamins> slef: Saint Andrews!
19:45:17 <paul_p> fishing trip++++++ !
19:45:21 * jwagner has been wanting to go to the Lake District for years
19:45:26 <dpavlin> From last KohaConf, we will be half-exsausted by 4th day, something easy please :-)
19:45:36 <jcamins> dpavlin: Saint Andrews is easy.
19:45:37 <slef> paul_p: Edinburgh and Glasgow have some international air links, but London is a big hub.
19:45:39 <jcamins> And beautiful.
19:45:42 <paul_p> is loch ness far from Edinburg ?
19:45:49 <jcamins> paul_p: easy day trip.
19:45:49 <slef> paul_p: heh. yes.
19:45:51 <dpavlin> Loch Ness++
19:46:09 <slef> I've no idea if that's doable in a day, but we can check. Update the wishlist wiki, please!
19:46:16 <thd> paul_p: flying direct to Edinburgh is more expensive from most places than direct to London.
19:46:39 <slef> But anyway, first we sort out the conf.
19:46:54 <Brooke> anything else?
19:46:55 <wahanui> it has been said that anything else is just piling mess on top
19:47:10 <slef> Not from me. Any questions?
19:47:13 <schuster> When we went years ago it was fly into London, take train to Edinburgh - I recommend the scotch museum...:)
19:47:27 <ibeardslee> scotch museum+++
19:47:53 <jcamins> Whiskey included with your admission ticket, if you're over 18.
19:47:58 <Brooke> #topic KohaCon2013
19:48:08 <slef> schuster: yes, there are fast trains from London King's Cross, sleepers from London Euston and cheap buses from London Victoria. This will be documented once we have dates.
19:48:49 <slef> schuster: but I will be travelling a non-straightforward route anyway, and I enjoyed the road trip, so I keep it in mind as a possibility.
19:49:05 <Brooke> personally, I think we should hold off on proposals until after Scotland; folks might be inspired to bid after the Conference that wouldn't before it
19:49:44 <mglavica> ops
19:49:47 <jenkins_koha> Project Koha_master build #558: STILL UNSTABLE in 1 h 41 mn: http://jenkins.koha-community.org/job/Koha_master/558/
19:49:47 <jenkins_koha> * paul.poulain: Jenkins complaining = fixing number of tests
19:49:49 <jenkins_koha> * Chris Cormack: Bug 5604 : Follow up for missing image
19:49:49 <huginn`> 04Bug http://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=5604 normal, PATCH-Sent, ---, nengard, ASSIGNED , additional icons for the Seshat set
19:50:05 <ibeardslee> the LCA announce their next conference at the conference
19:50:14 * Brooke nods
19:50:21 <Brooke> my Fraternity did it that way for 2 years out.
19:50:41 <ibeardslee> very handy for people to start the planning of travel etc
19:50:48 * Brooke nods.
19:50:51 <dpavlin> DebConf usually have at least proposal on conferece, and then continues to mail-it-to-death for a year
19:51:33 <dpavlin> We *might* propose Zagreb and our Univeristity librarary, but our fear is lack of commercial prospect in the region.
19:51:34 <thd> I am all for mail-it-to-death contests
19:51:42 <schuster> #info schuster - David Schuster Plano ISD.
19:51:55 <slef> I think debconf is currently proposing for 2013?
19:52:11 <tajoli> In theory koha 2013 for Africa or Soth America
19:52:18 <slef> there was mail about it today... I knew I should have read it properly ;-)
19:52:27 <Brooke> zeno would be nice but can't happen without folks stepping up
19:52:46 <jenkins_koha> Project Koha_3.4.x build #66: STILL UNSTABLE in 1 h 23 mn: http://jenkins.koha-community.org/job/Koha_3.4.x/66/
19:52:47 <jenkins_koha> * f.demians: 3.4.7 Translation Update
19:52:47 <jenkins_koha> * chris.nighswonger: Updating Version Number to 3.04.07.000
19:52:51 <Brooke> I hear a lot from Africa that they definitely want conference *sometime* but not _nexttime_
19:52:52 <jenkins_koha> Starting build 67 for job Koha_3.4.x (previous build: STILL UNSTABLE -- last SUCCESS #50 2 mo. 0 j ago)
19:53:39 <tajoli> I'm think of Venezuela. They don't speak abot a state version of Koha ?
19:53:45 <thd> Brooke, which countries do you hear from in Africa?
19:54:05 <Brooke> some Nigerians have mentioned it here and there, and way back there was rumour of SA
19:54:16 <slef> I would love it if we could get it if people were starting to propose kohacon X+2 at kohacon X. Is that doable?
19:54:42 <Brooke> if it's *at* KohaCon, it also has to be over IRC
19:54:43 <Brooke> imo
19:54:51 <dpavlin> +2 seems totally resonable.
19:54:54 <Brooke> because I don't want to disenfranchise folks that don't show to conference
19:55:06 <thd> Brooke++
19:55:16 <paul_p> I think i would prefer KohaCon with many attendees in a continent where we already had one more than a new continent with only a few attendees...
19:55:28 <tajoli> Clearly
19:55:35 <thd> paul_p++
19:55:46 <slef> Brooke: or video pitches.
19:55:47 <dpavlin> but we should shift continents yearly, right?
19:56:03 <paul_p> dpavlin, yes. But you know, UK is not really Europe :D :D :D
19:56:05 <Brooke> I think shifting it builds interest
19:56:07 <tajoli> For Zagreb is Ok for 2013
19:56:10 <thd> We should not make rules about venue location which primarily result in poor attendance.
19:56:17 <Brooke> but if we get a bid for Zagreb
19:56:20 <Brooke> and no one else bids
19:56:21 <Brooke> then
19:56:24 <Brooke> hooray :)
19:56:30 <slef> paul_p: stop trying to disown us. We still love you, despite Sarkozy!
19:56:50 <thd> It is perfectly reasonably for places with more interest in Koha to host more conferences.
19:56:54 <cait> paul_p++
19:57:18 <Brooke> thd that's what local conferences are made for
19:57:25 <Brooke> that and practice for international
19:57:36 <Brooke> if you hated hosting your local conference, you'd prolly loathe hosting KohaCon
19:57:42 <cait> zagreb++ :)
19:57:47 <Brooke> conversely, if you're a masochist, eyes wide open.
19:57:59 <thd> Brooke: You are correct about the purposes of local conferences.
19:58:26 <Brooke> again personally, I just don't want it to degrade into the US and EU have Conference 4 EVAR
19:58:57 <dpavlin> Let's consider Zagreb backup option for 2013.
19:59:14 <Brooke> dpavlin, I don't see any reason you can't start checking things out
19:59:17 <Brooke> worse comes to worst
19:59:24 <Brooke> you have information for next time round
19:59:33 <thd> Brooke: However, conference venue rotation rules should not force a venue where there is insufficient interest in actually organising a conference.
19:59:38 <Brooke> I think Zagreb would be neat
19:59:39 <paul_p> maybe what we should do now is drop a mail to koha ML to say "hey, who is interested to host KohaCon13" ?
19:59:57 <Brooke> insufficient interest would mean no proposal from that region thd
20:00:15 <slef> (dagnabbit where was that email about debconf?)
20:00:19 <slef> paul_p++
20:00:32 <cait> yes +1
20:00:55 <dpavlin> paul_p++
20:01:01 <thd> Brooke: Exactly, we should not push people hard to hold a conference in some location where we have not had one if they really have not enough interest to put themselves forward.
20:01:09 <Brooke> #action mail a proposal out to the list about hosting 2013
20:01:16 <slef> so does cait or dpavlin volunteer to send that email? ;-)
20:01:17 <paul_p> dpavlin, you start a wiki page & drop a mail to koha general ML ?
20:01:30 <slef> or do either want to bid? ;-)
20:01:36 * dpavlin grrr...
20:01:48 <thd> Brooke: Otherwise I agree completely about rotating locations and definitely not having US and EU in alternating turns.
20:01:53 <slef> or shall I? As we deffo won't bid.
20:02:23 <Brooke> you do it slef :P
20:02:32 * Brooke flexes her authoritay
20:02:33 <tajoli> In fact now the real option are USA, EU, India NZ, AU
20:02:38 <dpavlin> I think we might want to move away from Europe in 2013 if possible, but I would appiricate mailing list summary from somebody else since I'm not native speaker :-)
20:03:05 <cait> I like someone hosting who is present on lists and irc before offering
20:03:17 <drojf> cait++
20:03:42 <cait> if that makes sense
20:03:44 <schuster> Ya'll could come back to Plano TX USA, but I suspect you want to see another part of the US!  LOL...
20:03:55 <rangi> plano was fun
20:04:07 <rangi> and that media center was top notch
20:04:16 <thd> tajoli: I expect good proposals from all of those places and their near neighbours.
20:04:23 <paul_p> cait++
20:04:37 <paul_p> yep, plano was really great !
20:04:40 * oleonard would love a KohaCon in bag's neck of the woods
20:04:49 <Brooke> aye
20:04:57 <Brooke> or DC
20:04:58 <tajoli> But for example Pakistan (with users and firm) is quite difficult for many of us
20:05:00 <Brooke> ;)
20:05:16 <schuster> tks all...  I enjoyed having you all here.
20:05:47 <Brooke> so movin' on
20:05:55 <Brooke> #topic Koha Christmas Party
20:06:16 <Brooke> rangi, yes?
20:06:21 <thd> The longer ahead we could actually schedule a conference the better prospects people might have of obtaining low prices for the excursion.
20:06:44 <rangi> oh, we should have one
20:06:48 <rangi> and you should cater
20:06:51 <rangi> that is all
20:07:26 <oleonard> What is a Koha Christmas Party?
20:07:29 <rangi> someone suggested it on irc, so i put it on the agenda
20:07:30 <rangi> i have no idea
20:07:44 <sekjal> if it involves baked goods, I'm there!
20:08:04 <cait> heh
20:08:09 <cait> coookies!
20:08:09 <rangi> something like gbsd ... but with less work more talking rubbish on irc :)
20:08:20 <Brooke> *cough* we could do it over someone's Birthday
20:08:24 <JesseM> Send all gifts to HLT!
20:08:27 <Brooke> #justsayin
20:08:44 * oleonard doesn't need a holiday to talk rubbish on irc
20:08:45 <thd> rangi: yes GBSD in reverse.
20:08:46 <cait> so more like a friday than like gbsd :)
20:08:59 <sekjal> thd:  global bug-creating day?
20:09:12 <drojf> local
20:09:14 <Brooke> which Friday? Proper eNZed Friday, or that late Friday everyone else celebrates?
20:09:19 <oleonard> Sometimes I think that's what GBSD ends up being sekjal (or at least bug-finding)
20:10:32 <cait> oleonard++
20:10:37 <rangi> hmmm down 2 only 4 fails on master
20:10:50 <francharb> bye all!
20:10:56 <rangi> cya francharb
20:11:03 <francharb> have a nice day/night!
20:11:09 <francharb> :)
20:11:09 <paul_p> rangi, yep. And I think 2 are duplicates (or 2 reports of 1 problem)
20:11:28 <rangi> paul_p: ill look at the Record.pm one now
20:11:35 <rangi> then perl critic after
20:11:36 <paul_p> (the testcritic one)
20:11:39 <Brooke> so no holiday party?
20:11:53 * slef mutters about a 23 Dec meeting he has to attend
20:11:56 <Brooke> #topic Olde Business and Miscellanea
20:12:12 <Brooke> any other crap we've not beaten to a bloody pulp yet?
20:12:16 <francharb_afk> Brooke, i just saw that "koha christmas pary"
20:12:23 <francharb_afk> lucky you
20:12:25 <paul_p> the perlcritic comes from a patch to have pdf printing working. it's perlcritic level 3 iirc.
20:12:35 <francharb_afk> that's something we don"t have in france
20:12:38 <francharb_afk> sounds fun
20:12:45 <francharb_afk> even more on irc!
20:13:23 <paul_p> nope, it's level 5
20:13:31 <mtj2> bah, i gotta scoot now too - ciao all
20:13:32 <paul_p> 19:38 ~/koha.dev/koha-community (master $% u=)$ perlcritic acqui/basketgroup.pl Expression form of "eval" at line 190, column 9.  See page 161 of PBP.  (Severity: 5)
20:13:43 <thd> On old business which came out around the end of the last meeting ...
20:13:58 <thd> uploading files is working again for the wiki.
20:14:02 <Brooke> hooray
20:14:25 <Brooke> anything else?
20:14:25 <wahanui> anything else is just piling mess on top
20:14:26 <cait> yay :)
20:14:29 <cait> thd++
20:14:57 <oleonard> wahanui: That joke is wearing thin
20:14:58 <wahanui> OK, oleonard.
20:14:59 <slef> thd++
20:15:00 <thd> I fixed it three weeks ago but it failed when I tested but seems to be working with no intervening change except maybe an apache restart.
20:15:06 <Brooke> #topic Next Meeting
20:15:08 <slef> that joke?
20:15:08 <wahanui> that joke is wearing thin
20:15:08 <dpavlin> Where do I configure database which t/db_dependent uses? in current KOHA_CONF ?
20:15:59 <dpavlin> Should we suggest to run tests under new database, so that people don't run it on production by mistake?
20:16:03 <rangi> dpavlin: yes
20:16:15 <rangi> good idea
20:16:28 <Brooke> 4 January 10 UTC?
20:17:05 <paul_p> sounds OK
20:17:27 <jcamins> dpavlin: yeah, it's just your regular Koha installation.
20:17:32 <jcamins> First Wednesday of next month, minus eight hours?
20:17:34 <jcamins> Sounds fine to me, though I won't be able to make it.
20:17:35 <cait> yep
20:17:36 <thd> +1 4 Jan. 10 UTC
20:17:37 <jcamins> Seems more fair to cait, et. al.
20:17:51 <cait> jcamins: hm?
20:18:04 <cait> oh, the time
20:18:05 <wahanui> rumour has it the time is a scary thing
20:18:30 <jcamins> Yup.
20:18:35 <slef> +1 2012-01-04 10:00:00 +0000
20:18:58 <Brooke> #agreed 4 January 10 UTC
20:19:02 <Brooke> #endmeeting